java.lang.ClassNotFoundException

oracle.adf.view.faces.bi.webapp.MapProxyServlet from [Module "deployment.ola_ViewController_webapp.war:main" from Service Module Loader]

Samebug tips1

Check if the version of resteasy is using is the same JBoss is using. To find it out, search for resteasy-jaxrs* in JBoss/Wildfly directory and at your pom.xml.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web2975

  • oracle.adf.view.faces.bi.webapp.MapProxyServlet from [Module "deployment.ola_ViewController_webapp.war:main" from Service Module Loader]
  • oracle.adf.view.faces.bi.webapp.MapProxyServlet from [Module "deployment.ola_ViewController_webapp.war:main" from Service Module Loader]
  • org.hibernate.service.spi.BasicServiceInitiator from [Module "deployment.application.war:main" from Service Module Loader]
  • Stack trace

    • java.lang.ClassNotFoundException: oracle.adf.view.faces.bi.webapp.MapProxyServlet from [Module "deployment.ola_ViewController_webapp.war:main" from Service Module Loader] at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)[jboss-modules.jar:1.1.1.GA] at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)[jboss-modules.jar:1.1.1.GA] at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)[jboss-modules.jar:1.1.1.GA] at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)[jboss-modules.jar:1.1.1.GA] at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)[jboss-modules.jar:1.1.1.GA] at java.lang.Class.forName0(Native Method)[rt.jar:1.7.0_04] at java.lang.Class.forName(Class.java:264)[rt.jar:1.7.0_04] at org.jboss.as.server.deployment.reflect.DeploymentClassIndex.classIndex(DeploymentClassIndex.java:54)[jboss-as-server-7.1.1.Final.jar:7.1.1.Final] at org.jboss.as.ee.component.deployers.EEModuleConfigurationProcessor.deploy(EEModuleConfigurationProcessor.java:79) at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113)[jboss-as-server-7.1.1.Final.jar:7.1.1.Final] at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)[jboss-msc-1.0.2.GA.jar:1.0.2.GA] at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)[jboss-msc-1.0.2.GA.jar:1.0.2.GA] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)[rt.jar:1.7.0_04] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)[rt.jar:1.7.0_04] at java.lang.Thread.run(Thread.java:722)[rt.jar:1.7.0_04]

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Once, 1 month ago
    92 times, 8 months ago
    2 times, 9 months ago
    Unknown user
    Once, 10 months ago
    81 more bugmates