java.lang.ClassNotFoundException

If you like a tip written by other Samebug users, mark is as helpful! Marks help our algorithm provide you better solutions and also help other users.
tip

Check if the version of resteasy is using is the same JBoss is using. To find it out, search for resteasy-jaxrs* in JBoss/Wildfly directory and at your pom.xml.

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Auto deploy app with jar library
    via Stack Overflow by user902691
    ,
  • RE: Primefaces in 6.2 - Community Forums | Liferay
    via by Unknown author,
  • How to deploy mule app on JBOSS server
    via Stack Overflow by user3855589
    ,
    • java.lang.ClassNotFoundException: oracle.adf.view.faces.bi.webapp.GaugeServlet from [Module "deployment.ola_ViewController_webapp.war:main" from Service Module Loader] at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)[jboss-modules.jar:1.1.1.GA] at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)[jboss-modules.jar:1.1.1.GA] at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)[jboss-modules.jar:1.1.1.GA] at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)[jboss-modules.jar:1.1.1.GA] at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)[jboss-modules.jar:1.1.1.GA] at java.lang.Class.forName0(Native Method)[rt.jar:1.7.0_04] at java.lang.Class.forName(Class.java:264)[rt.jar:1.7.0_04] at org.jboss.as.server.deployment.reflect.DeploymentClassIndex.classIndex(DeploymentClassIndex.java:54)[jboss-as-server-7.1.1.Final.jar:7.1.1.Final] at org.jboss.as.ee.component.deployers.EEModuleConfigurationProcessor.deploy(EEModuleConfigurationProcessor.java:79) at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113)[jboss-as-server-7.1.1.Final.jar:7.1.1.Final] at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)[jboss-msc-1.0.2.GA.jar:1.0.2.GA] at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)[jboss-msc-1.0.2.GA.jar:1.0.2.GA] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)[rt.jar:1.7.0_04] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)[rt.jar:1.7.0_04] at java.lang.Thread.run(Thread.java:722)[rt.jar:1.7.0_04]

    Users with the same issue

    Unknown visitor1 times, last one,
    Andreas Häber
    1 times, last one,
    andyglick
    92 times, last one,
    pbabcsany
    2 times, last one,
    Unknown visitor1 times, last one,
    81 more bugmates