java.lang.IllegalStateException: Can't install feature onos-providers-openflow-base/0.0.0: Could not start bundle mvn:org.onosproject/onos-providers-openflow-device/1.7.0-SNAPSHOT in feature(s) onos-providers-openflow-base-1.7.0-SNAPSHOT: Unresolved constraint in bundle org.onosproject.onos-providers-openflow-device [163]: Unable to resolve 163.0: missing requirement [163.0] osgi.wiring.package; (&(osgi.wiring.package=org.onosproject.net.optical.device)(version>=1.7.0)(!(version>=2.0.0)))

JIRA | Ray Milkey | 4 months ago
  1. 0

    Occasionally the events that trigger loading of required applications for the openflow meta app get delivered out of order, and apps that are required are loaded after the meta app. Here is an example stack trace: 2016-08-10 22:21:44,178 | WARN | -message-handler | ApplicationManager | 76 - org.onosproject.onos-core-net - 1.7.0.SNAPSHOT | Unable to perform operation on application org.onosproject.openflow-base java.lang.IllegalStateException: Can't install feature onos-providers-openflow-base/0.0.0: Could not start bundle mvn:org.onosproject/onos-providers-openflow-device/1.7.0-SNAPSHOT in feature(s) onos-providers-openflow-base-1.7.0-SNAPSHOT: Unresolved constraint in bundle org.onosproject.onos-providers-openflow-device [163]: Unable to resolve 163.0: missing requirement [163.0] osgi.wiring.package; (&(osgi.wiring.package=org.onosproject.net.optical.device)(version>=1.7.0)(!(version>=2.0.0))) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:405) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:373) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:351) at Proxy2f5c7ac0_3d59_4dae_bba3_203c1f78f885.installFeature(Unknown Source) at org.onosproject.app.impl.ApplicationManager.installAppFeatures(ApplicationManager.java:283) at org.onosproject.app.impl.ApplicationManager.access$200(ApplicationManager.java:66) at org.onosproject.app.impl.ApplicationManager$InternalStoreDelegate.notify(ApplicationManager.java:210) at org.onosproject.app.impl.ApplicationManager$InternalStoreDelegate.notify(ApplicationManager.java:202) at org.onosproject.store.app.DistributedApplicationStore.setupApplicationAndNotify(DistributedApplicationStore.java:484)[78:org.onosproject.onos-core-dist:1.7.0.SNAPSHOT] at org.onosproject.store.app.DistributedApplicationStore.access$500(DistributedApplicationStore.java:94)[78:org.onosproject.onos-core-dist:1.7.0.SNAPSHOT] at org.onosproject.store.app.DistributedApplicationStore$InternalAppsListener.event(DistributedApplicationStore.java:467) at org.onosproject.store.primitives.impl.MeteredAsyncConsistentMap$InternalMeteredMapEventListener.event(MeteredAsyncConsistentMap.java:291) at org.onosproject.store.primitives.impl.TranscodingAsyncConsistentMap$InternalBackingMapEventListener.event(TranscodingAsyncConsistentMap.java:311) at org.onosproject.store.primitives.resources.impl.AtomixConsistentMap.lambda$null$2(AtomixConsistentMap.java:102) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_101] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_101] at java.lang.Thread.run(Thread.java:745)[:1.8.0_101]

    JIRA | 4 months ago | Ray Milkey
    java.lang.IllegalStateException: Can't install feature onos-providers-openflow-base/0.0.0: Could not start bundle mvn:org.onosproject/onos-providers-openflow-device/1.7.0-SNAPSHOT in feature(s) onos-providers-openflow-base-1.7.0-SNAPSHOT: Unresolved constraint in bundle org.onosproject.onos-providers-openflow-device [163]: Unable to resolve 163.0: missing requirement [163.0] osgi.wiring.package; (&(osgi.wiring.package=org.onosproject.net.optical.device)(version>=1.7.0)(!(version>=2.0.0)))
  2. 0

    The SNMP app will not start up due to unsatisfied dependencies. 2016-10-26 18:11:50,227 | WARN | -message-handler | ApplicationManager | 76 - org.onosproject.onos-core-net - 1.8.0.SNAPSHOT | Unable to perform operation on application org.onosproject.snmp java.lang.IllegalStateException: Can't install feature onos-snmp-app/0.0.0: Could not start bundle mvn:org.onosproject/mibbler-mibs-bti7000/1.0-20151221.1 in feature(s) onos-snmp-app-1.8.0-SNAPSHOT: Unresolved constraint in bundle bti7000 [198]: Unable to resolve 198.0: missing requirement [198.0] osgi.wiring.package; (&(osgi.wiring.package=com.btisystems.mibbler.mibs.netsnmp.netsnmp.mib_2)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 199.0: missing requirement [199.0] osgi.wiring.package; (&(osgi.wiring.package=com.btisystems.mibbler.mibs.rfc.rfc.mib_2.dot1dbridge)(version>=1.0.0)(!(version>=2.0.0)))] at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:405) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:373) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:351) at Proxy36efcf9e_5686_4119_bc3c_d8b04a5fc626.installFeature(Unknown Source) at org.onosproject.app.impl.ApplicationManager.installAppFeatures(ApplicationManager.java:277) at org.onosproject.app.impl.ApplicationManager.access$200(ApplicationManager.java:66) at org.onosproject.app.impl.ApplicationManager$InternalStoreDelegate.notify(ApplicationManager.java:204) at org.onosproject.app.impl.ApplicationManager$InternalStoreDelegate.notify(ApplicationManager.java:196) at org.onosproject.store.AbstractStore.notifyDelegate(AbstractStore.java:58)[74:org.onosproject.onos-api:1.8.0.SNAPSHOT] at org.onosproject.store.app.DistributedApplicationStore.access$500(DistributedApplicationStore.java:95)[78:org.onosproject.onos-core-dist:1.8.0.SNAPSHOT] at org.onosproject.store.app.DistributedApplicationStore$AppActivator.accept(DistributedApplicationStore.java:439)[78:org.onosproject.onos-core-dist:1.8.0.SNAPSHOT] at org.onosproject.store.app.DistributedApplicationStore$AppActivator.accept(DistributedApplicationStore.java:433)[78:org.onosproject.onos-core-dist:1.8.0.SNAPSHOT] at org.onosproject.store.primitives.impl.DefaultDistributedTopic.lambda$null$0(DefaultDistributedTopic.java:67) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_101] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_101] at java.lang.Thread.run(Thread.java:745)[:1.8.0_101]

    JIRA | 1 month ago | Ray Milkey
    java.lang.IllegalStateException: Can't install feature onos-snmp-app/0.0.0: Could not start bundle mvn:org.onosproject/mibbler-mibs-bti7000/1.0-20151221.1 in feature(s) onos-snmp-app-1.8.0-SNAPSHOT: Unresolved constraint in bundle bti7000 [198]: Unable to resolve 198.0: missing requirement [198.0] osgi.wiring.package; (&(osgi.wiring.package=com.btisystems.mibbler.mibs.netsnmp.netsnmp.mib_2)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 199.0: missing requirement [199.0] osgi.wiring.package; (&(osgi.wiring.package=com.btisystems.mibbler.mibs.rfc.rfc.mib_2.dot1dbridge)(version>=1.0.0)(!(version>=2.0.0)))]
  3. 0

    Camel - Users - MINA TLS: Silent Error when trying to load a MINA route with TLS

    nabble.com | 1 year ago
    java.lang.IllegalStateException: Can't install feature ngms-hl7v2-listener/0.0.0: Could not start bundle mvn:com.nextgate.ms.components.adapters/ngms-listener-hl7v2-mllp/1.0.0-SNAPSHOT in feature(s) ngms-hl7v2-listener-1.0.0-SNAPSHOT: Activator start error in bundle com.nextgate.ms.components.adapters.ngms-listener-hl7v2-mllp [316].
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    hawtio 1.4.60 cannot install on servicemix 6.0.2

    GitHub | 10 months ago | twalzer
    java.lang.IllegalStateException: Can't install feature hawtio/0.0.0: Can not resolve feature: Unsatisfied requirement(s): --------------------------- package:(&(package=org.apache.karaf.shell.console)(version>=4.0.0)(!(version>=5.0.0))) hawtio :: Karaf terminal plugin
  6. 0

    GitHub comment 77#192254694

    GitHub | 9 months ago | ElisaRojas
    java.lang.IllegalStateException: Can't install feature onos-app-shim/0.0.0: Could not start bundle mvn:eu.netide/onos-app-shim/1.0.0-SNAPSHOT in feature(s) onos-app-shim-1.0.0-SNAPSHOT: Uses constraint violation. Unable to resolve bundle revision eu.netide.onos-app-shim [184.0] because it is exposed to package 'org.projectfloodlight.openflow.protocol' from bundle revisions netip [183.0] and org.onosproject.onos-of-api [161.0] via two dependency chains. Chain 1: eu.netide.onos-app-shim [184.0] import: (&(osgi.wiring.package=org.projectfloodlight.openflow.protocol)(version>=1.1.0)(!(version>=2.0.0))) | export: osgi.wiring.package=org.projectfloodlight.openflow.protocol netip [183.0] Chain 2: eu.netide.onos-app-shim [184.0] import: (&(osgi.wiring.package=org.onosproject.openflow.controller)(version>=1.4.0)(!(version>=2.0.0))) | export: osgi.wiring.package=org.onosproject.openflow.controller; uses:=org.projectfloodlight.openflow.protocol export: osgi.wiring.package=org.projectfloodlight.openflow.protocol org.onosproject.onos-of-api [161.0]

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.IllegalStateException

      Can't install feature onos-providers-openflow-base/0.0.0: Could not start bundle mvn:org.onosproject/onos-providers-openflow-device/1.7.0-SNAPSHOT in feature(s) onos-providers-openflow-base-1.7.0-SNAPSHOT: Unresolved constraint in bundle org.onosproject.onos-providers-openflow-device [163]: Unable to resolve 163.0: missing requirement [163.0] osgi.wiring.package; (&(osgi.wiring.package=org.onosproject.net.optical.device)(version>=1.7.0)(!(version>=2.0.0)))

      at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature()
    2. Pax Runner
      FeaturesServiceImpl.installFeature
      1. org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:405)
      2. org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:373)
      3. org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:351)
      3 frames
    3. Unknown
      Proxy2f5c7ac0_3d59_4dae_bba3_203c1f78f885.installFeature
      1. Proxy2f5c7ac0_3d59_4dae_bba3_203c1f78f885.installFeature(Unknown Source)
      1 frame
    4. org.onosproject.app
      ApplicationManager$InternalStoreDelegate.notify
      1. org.onosproject.app.impl.ApplicationManager.installAppFeatures(ApplicationManager.java:283)
      2. org.onosproject.app.impl.ApplicationManager.access$200(ApplicationManager.java:66)
      3. org.onosproject.app.impl.ApplicationManager$InternalStoreDelegate.notify(ApplicationManager.java:210)
      4. org.onosproject.app.impl.ApplicationManager$InternalStoreDelegate.notify(ApplicationManager.java:202)
      4 frames
    5. org.onosproject.store
      AtomixConsistentMap.lambda$null$2
      1. org.onosproject.store.app.DistributedApplicationStore.setupApplicationAndNotify(DistributedApplicationStore.java:484)[78:org.onosproject.onos-core-dist:1.7.0.SNAPSHOT]
      2. org.onosproject.store.app.DistributedApplicationStore.access$500(DistributedApplicationStore.java:94)[78:org.onosproject.onos-core-dist:1.7.0.SNAPSHOT]
      3. org.onosproject.store.app.DistributedApplicationStore$InternalAppsListener.event(DistributedApplicationStore.java:467)
      4. org.onosproject.store.primitives.impl.MeteredAsyncConsistentMap$InternalMeteredMapEventListener.event(MeteredAsyncConsistentMap.java:291)
      5. org.onosproject.store.primitives.impl.TranscodingAsyncConsistentMap$InternalBackingMapEventListener.event(TranscodingAsyncConsistentMap.java:311)
      6. org.onosproject.store.primitives.resources.impl.AtomixConsistentMap.lambda$null$2(AtomixConsistentMap.java:102)
      6 frames
    6. Java RT
      Thread.run
      1. java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_101]
      2. java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_101]
      3. java.lang.Thread.run(Thread.java:745)[:1.8.0_101]
      3 frames