java.lang.IllegalArgumentException: Failed to parse 1 as version number

Google Groups | Rafael Rezende | 9 months ago
tip
Do you know that we can give you better hits? Get more relevant results from Samebug’s stack trace search.
  1. 0

    Maven HPI plugin does not accept 1-digit dependency version

    Google Groups | 9 months ago | Rafael Rezende
    java.lang.IllegalArgumentException: Failed to parse 1 as version number

    Root Cause Analysis

    1. java.lang.IllegalArgumentException

      Failed to parse 1 as version number

      at org.jenkinsci.maven.plugins.hpi.VersionNumber.<init>()
    2. org.jenkinsci.maven
      RunMojo.execute
      1. org.jenkinsci.maven.plugins.hpi.VersionNumber.<init>(VersionNumber.java:78)
      2. org.jenkinsci.maven.plugins.hpi.RunMojo.versionOfPlugin(RunMojo.java:395)
      3. org.jenkinsci.maven.plugins.hpi.RunMojo.versionOfPlugin(RunMojo.java:397)
      4. org.jenkinsci.maven.plugins.hpi.RunMojo.copyPlugin(RunMojo.java:374)
      5. org.jenkinsci.maven.plugins.hpi.RunMojo.execute(RunMojo.java:329)
      5 frames