com.atlassian.plugin.PluginParseException: Plugin keys cannot contain ':'. Key is 'com.atlassian.bamboo.plugin:bamboo-build-times-plugin'

Atlassian JIRA | Eric Dalgliesh | 3 years ago
  1. 0

    Starting Bamboo up, I get this message: {code} 2014-02-03 09:47:31,156 ERROR [localhost-startStop-1] [ScanningPluginLoader] Unable to deploy plugin 'com.atlassian.bamboo.plugin:bamboo-build-times-plugin', file Unit: /opt/atlassian/bamboo/data/plugins/plugin_4959531026609809494_bamboo-build-times-plugin-1.1.3.jar (1390878681000) com.atlassian.plugin.PluginParseException: Plugin keys cannot contain ':'. Key is 'com.atlassian.bamboo.plugin:bamboo-build-times-plugin' at com.atlassian.plugin.parsers.XmlDescriptorParser.configurePlugin(XmlDescriptorParser.java:122) at com.atlassian.plugin.osgi.factory.OsgiPluginFactory.create(OsgiPluginFactory.java:254) at com.atlassian.plugin.loaders.ScanningPluginLoader.deployPluginFromUnit(ScanningPluginLoader.java:116) at com.atlassian.plugin.loaders.ScanningPluginLoader.loadAllPlugins(ScanningPluginLoader.java:89) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:158) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:194) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:155) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:188) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:93) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4887) at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5381) at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150) {code}

    Atlassian JIRA | 3 years ago | Eric Dalgliesh
    com.atlassian.plugin.PluginParseException: Plugin keys cannot contain ':'. Key is 'com.atlassian.bamboo.plugin:bamboo-build-times-plugin'
  2. 0

    Starting Bamboo up, I get this message: {code} 2014-02-03 09:47:31,156 ERROR [localhost-startStop-1] [ScanningPluginLoader] Unable to deploy plugin 'com.atlassian.bamboo.plugin:bamboo-build-times-plugin', file Unit: /opt/atlassian/bamboo/data/plugins/plugin_4959531026609809494_bamboo-build-times-plugin-1.1.3.jar (1390878681000) com.atlassian.plugin.PluginParseException: Plugin keys cannot contain ':'. Key is 'com.atlassian.bamboo.plugin:bamboo-build-times-plugin' at com.atlassian.plugin.parsers.XmlDescriptorParser.configurePlugin(XmlDescriptorParser.java:122) at com.atlassian.plugin.osgi.factory.OsgiPluginFactory.create(OsgiPluginFactory.java:254) at com.atlassian.plugin.loaders.ScanningPluginLoader.deployPluginFromUnit(ScanningPluginLoader.java:116) at com.atlassian.plugin.loaders.ScanningPluginLoader.loadAllPlugins(ScanningPluginLoader.java:89) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:158) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:194) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:155) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:188) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:93) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4887) at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5381) at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150) {code}

    Atlassian JIRA | 3 years ago | Eric Dalgliesh
    com.atlassian.plugin.PluginParseException: Plugin keys cannot contain ':'. Key is 'com.atlassian.bamboo.plugin:bamboo-build-times-plugin'
  3. 0

    Its likely the plugin is not working correctly. {noformat} 2011-09-08 11:44:16,212 ERROR [main] [XmlDescriptorParser] There were problems loading the module 'commandDecorator' in plugin 'Maven Artifact Sharing'. The module has been disabled. 2011-09-08 11:44:16,213 ERROR [main] [XmlDescriptorParser] Cannot find ModuleDescriptor class for plugin of type 'commandDecorator'. com.atlassian.plugin.PluginParseException: Cannot find ModuleDescriptor class for plugin of type 'commandDecorator'. at com.atlassian.plugin.DefaultModuleDescriptorFactory.getModuleDescriptor(DefaultModuleDescriptorFactory.java:75) at com.atlassian.plugin.parsers.XmlDescriptorParser.createModuleDescriptor(XmlDescriptorParser.java:190) at com.atlassian.plugin.parsers.XmlDescriptorParser.configurePlugin(XmlDescriptorParser.java:142) at com.atlassian.plugin.loaders.SinglePluginLoader.loadPlugin(SinglePluginLoader.java:135) at com.atlassian.plugin.loaders.SinglePluginLoader.loadAllPlugins(SinglePluginLoader.java:89) at com.atlassian.plugin.loaders.ClassPathPluginLoader.loadClassPathPlugins(ClassPathPluginLoader.java:59) at com.atlassian.plugin.loaders.ClassPathPluginLoader.loadAllPlugins(ClassPathPluginLoader.java:67) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:136) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:171) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:135) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:75) {noformat}

    Atlassian JIRA | 5 years ago | James Dumay [Atlassian]
    com.atlassian.plugin.PluginParseException: Cannot find ModuleDescriptor class for plugin of type 'commandDecorator'.
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Its likely the plugin is not working correctly. {noformat} 2011-09-08 11:44:16,212 ERROR [main] [XmlDescriptorParser] There were problems loading the module 'commandDecorator' in plugin 'Maven Artifact Sharing'. The module has been disabled. 2011-09-08 11:44:16,213 ERROR [main] [XmlDescriptorParser] Cannot find ModuleDescriptor class for plugin of type 'commandDecorator'. com.atlassian.plugin.PluginParseException: Cannot find ModuleDescriptor class for plugin of type 'commandDecorator'. at com.atlassian.plugin.DefaultModuleDescriptorFactory.getModuleDescriptor(DefaultModuleDescriptorFactory.java:75) at com.atlassian.plugin.parsers.XmlDescriptorParser.createModuleDescriptor(XmlDescriptorParser.java:190) at com.atlassian.plugin.parsers.XmlDescriptorParser.configurePlugin(XmlDescriptorParser.java:142) at com.atlassian.plugin.loaders.SinglePluginLoader.loadPlugin(SinglePluginLoader.java:135) at com.atlassian.plugin.loaders.SinglePluginLoader.loadAllPlugins(SinglePluginLoader.java:89) at com.atlassian.plugin.loaders.ClassPathPluginLoader.loadClassPathPlugins(ClassPathPluginLoader.java:59) at com.atlassian.plugin.loaders.ClassPathPluginLoader.loadAllPlugins(ClassPathPluginLoader.java:67) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:136) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:171) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:135) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:75) {noformat}

    Atlassian JIRA | 5 years ago | James Dumay [Atlassian]
    com.atlassian.plugin.PluginParseException: Cannot find ModuleDescriptor class for plugin of type 'commandDecorator'.
  6. 0

    [JRA-8009] java.lang.IllegalStateException: getAttribute: Session already invalidated when trying to call getAvailableActions or getFieldsForAction - Atlassian JIRA

    atlassian.com | 6 months ago
    com.atlassian.plugin.PluginParseException: Duplicate plugin key found: 'com.atlassian.jira.ext.rpc'

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. com.atlassian.plugin.PluginParseException

      Plugin keys cannot contain ':'. Key is 'com.atlassian.bamboo.plugin:bamboo-build-times-plugin'

      at com.atlassian.plugin.parsers.XmlDescriptorParser.configurePlugin()
    2. com.atlassian.plugin
      DefaultPluginManager.init
      1. com.atlassian.plugin.parsers.XmlDescriptorParser.configurePlugin(XmlDescriptorParser.java:122)
      2. com.atlassian.plugin.osgi.factory.OsgiPluginFactory.create(OsgiPluginFactory.java:254)
      3. com.atlassian.plugin.loaders.ScanningPluginLoader.deployPluginFromUnit(ScanningPluginLoader.java:116)
      4. com.atlassian.plugin.loaders.ScanningPluginLoader.loadAllPlugins(ScanningPluginLoader.java:89)
      5. com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:158)
      5 frames
    3. com.atlassian.bamboo
      UpgradeLauncher.contextInitialized
      1. com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:194)
      2. com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:155)
      3. com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:188)
      4. com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:93)
      5. com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39)
      5 frames
    4. Glassfish Core
      LifecycleBase.start
      1. org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4887)
      2. org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5381)
      3. org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
      3 frames