java.lang.NoClassDefFoundError

hr/combis/proxy/util/ServiceExecutor

Solutions on the web2481

  • via Oracle Community by kicho, 11 months ago
    hr/combis/proxy/util/ServiceExecutor
  • javassist/util/proxy/Proxy
  • javassist/util/proxy/Proxy
  • Stack trace

    • java.lang.NoClassDefFoundError: hr/combis/proxy/util/ServiceExecutor at java.lang.Class.getDeclaredMethods0(Native Method) at java.lang.Class.privateGetDeclaredMethods(Class.java:2427) at java.lang.Class.getMethod0(Class.java:2670) at java.lang.Class.getMethod(Class.java:1603) at com.sun.xml.ws.modeler.RuntimeModeler.processMethod(RuntimeModeler.java:455) at com.sun.xml.ws.modeler.RuntimeModeler.processClass(RuntimeModeler.java:355) at com.sun.xml.ws.modeler.RuntimeModeler.buildRuntimeModel(RuntimeModeler.java:251) at com.sun.tools.ws.wscompile.CompileTool.buildModel(CompileTool.java:633) at com.sun.tools.ws.wscompile.CompileTool.run(CompileTool.java:538) at com.sun.tools.ws.util.ToolBase.run(ToolBase.java:56) at com.sun.tools.ws.util.WSToolsObjectFactoryImpl.wsgen(WSToolsObjectFactoryImpl.java:44) at com.sun.enterprise.webservice.WsUtil.runWsGen(WsUtil.java:1820) at com.sun.enterprise.webservice.WsUtil.genWSInfo(WsUtil.java:2089) at com.sun.enterprise.deployment.backend.AppDeployerBase.loadDescriptors(AppDeployerBase.java:328) at com.sun.enterprise.deployment.backend.AppDeployer.explodeArchive(AppDeployer.java:332) at com.sun.enterprise.deployment.backend.AppDeployer.deploy(AppDeployer.java:182) at com.sun.enterprise.deployment.backend.AppDeployer.doRequestFinish(AppDeployer.java:129) at com.sun.enterprise.deployment.phasing.J2EECPhase.runPhase(J2EECPhase.java:169) at com.sun.enterprise.deployment.phasing.DeploymentPhase.executePhase(DeploymentPhase.java:95) at com.sun.enterprise.deployment.phasing.PEDeploymentService.executePhases(PEDeploymentService.java:871) at com.sun.enterprise.deployment.phasing.PEDeploymentService.deploy(PEDeploymentService.java:266) at com.sun.enterprise.deployment.phasing.PEDeploymentService.deploy(PEDeploymentService.java:739) at com.sun.enterprise.management.deploy.DeployThread.deploy(DeployThread.java:174) at com.sun.enterprise.management.deploy.DeployThread.run(DeployThread.java:210)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 9 months ago
    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    2 times, 1 year ago
    79 more bugmates