org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.security.web [20]: Unable to resolve 20.0: missing requirement [20.0] pa ckage; (&(package=javax.servlet)(version>=0.0.0))

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

Do you know how to solve this issue? Write a tip to help other users and build your expert profile.

Solutions on the web

via GitHub by albagarcia
, 1 year ago
Unresolved constraint in bundle org.springfr amework.security.web [20]: Unable to resolve 20.0: missing requirement [20.0] pa ckage; (&(package=javax.servlet)(version>=0.0.0))
via GitHub by rchawdry
, 2 years ago
Unresolved constraint in bundle org.apache.sshd.core [20]: Unable to resolve 20.0: missing requirement [20.0] package; (package=javax.crypto)
via GitHub by aowen
, 10 months ago
Unresolved constraint in bundle org.apache.sshd.core [20]: Unable to resolve 20.0: missing requirement [20.0] package; (package=javax.crypto) ```
via smartbear.com by Unknown author, 2 years ago
Unresolved constraint in bundle org.eclipse.jetty.io [20]: Unable to resolve 20.0: missing requirement [20.0] package; (package=javax.net.ssl)
via Google Groups by Carolina Bijou, 4 months ago
Unresolved constraint in bundle org.apache.k araf.shell.console [20]: Unable to resolve 20.0: missing requirement [20.0] pack age; (package=javax.security.auth)
via Spring JIRA by Artem, 1 year ago
Unresolved constraint in bundle org.springframework.roo.addon.creator [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation)]
org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.security.web [20]: Unable to resolve 20.0: missing requirement [20.0] pa ckage; (&(package=javax.servlet)(version>=0.0.0))
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1143)
at java.lang.Thread.run(Thread.java:744)

Users with the same issue

2 times, 9 months ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.