Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

  1. ,
    via Google Groups by Marcus Haebler

    Update "latest" to Java 8 on DockerHub.

  2. ,
    via Stack Overflow by ERJAN

    This exception occurs when using an older version of java. Mainly when trying to run a jar compiled with a newer Java version in an older Java version. We can avoid this issue by executing the jar in the same version which it was compiled.

Solutions on the web

via GitHub by Mr-Vuda
, 1 year ago
java.lang.UnsupportedClassVersionError: com/comze_instancelabs/minigamesapi/MinigamesAPI : Unsupported major.minor version 52.0
via GitHub by LeonP-S
, 2 years ago
java.lang.UnsupportedClassVersionError: com/j0ach1mmall3/permissionsshop/Main : Unsupported major.minor version 52.0
via GitHub by ipozow
, 2 years ago
java.lang.UnsupportedClassVersionError: com/j0ach1mmall3/permissionsshop/Main : Unsupported major.minor version 52.0
via spigotmc.org by Unknown author, 1 year ago
java.lang.UnsupportedClassVersionError: homepackage/homeplugin : Unsupported major.minor version 52.0
via GitHub by bykidi
, 1 year ago
java.lang.UnsupportedClassVersionError: fr/xephi/authme/AuthMe : Unsupported major.minor version 52.0
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/comze_instancelabs/minigamesapi/MinigamesAPI : Unsupported major.minor version 52.0 at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135)[spigot-1.8.8.jar:git-Spigot-6c9b0a1-de5c261] at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329)[spigot-1.8.8.jar:git-Spigot-6c9b0a1-de5c261] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:275)[spigot-1.8.8.jar:git-Spigot-6c9b0a1-de5c261] at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:291)[spigot-1.8.8.jar:git-Spigot-6c9b0a1-de5c261] at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198)[spigot-1.8.8.jar:git-Spigot-6c9b0a1-de5c261] at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:524)[spigot-1.8.8.jar:git-Spigot-6c9b0a1-de5c261] at java.lang.Thread.run(Unknown Source)[?:1.7.0_80]Caused by: java.lang.UnsupportedClassVersionError: com/comze_instancelabs/minigamesapi/MinigamesAPI : Unsupported major.minor version 52.0 at java.lang.ClassLoader.defineClass1(Native Method)[?:1.7.0_80] at java.lang.ClassLoader.defineClass(Unknown Source)[?:1.7.0_80] at java.security.SecureClassLoader.defineClass(Unknown Source)[?:1.7.0_80] at java.net.URLClassLoader.defineClass(Unknown Source)[?:1.7.0_80] at java.net.URLClassLoader.access$100(Unknown Source)[?:1.7.0_80] at java.net.URLClassLoader$1.run(Unknown Source)[?:1.7.0_80] at java.net.URLClassLoader$1.run(Unknown Source)[?:1.7.0_80] at java.security.AccessController.doPrivileged(Native Method)[?:1.7.0_80] at java.net.URLClassLoader.findClass(Unknown Source)[?:1.7.0_80] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101)[spigot-1.8.8.jar:git-Spigot-6c9b0a1-de5c261] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86)[spigot-1.8.8.jar:git-Spigot-6c9b0a1-de5c261] at java.lang.ClassLoader.loadClass(Unknown Source)[?:1.7.0_80] at java.lang.ClassLoader.loadClass(Unknown Source)[?:1.7.0_80] at java.lang.Class.forName0(Native Method)[?:1.7.0_80] at java.lang.Class.forName(Unknown Source)[?:1.7.0_80] at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64)[spigot-1.8.8.jar:git-Spigot-6c9b0a1-de5c261] at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131)[spigot-1.8.8.jar:git-Spigot-6c9b0a1-de5c261] ... 6 more