java.lang.NoClassDefFoundError: com/sap/mw/jco/JCO$Exception

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Oracle Community by 392 Guest, 1 year ago
com/sap/mw/jco/JCO$Exception
via opencrx by ev_ojeda
, 1 year ago
org/openmdx/base/exception/ServiceException
via Stack Overflow by Sandeep Kumar
, 2 years ago
com/thoughtworks/xstream/io/HierarchicalStreamDriver
via Oracle Community by 432667, 1 year ago
com/oracle/bpel/client/IBPELProcessHandle
via GitHub by waleed-dawood-confiz
, 2 years ago
com/google/inject/Module
via gmane.org by Unknown author, 2 years ago
com/google/inject/Module
java.lang.NoClassDefFoundError: com/sap/mw/jco/JCO$Exception
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Class.java:2427)
at java.lang.Class.privateGetPublicMethods(Class.java:2547)
at java.lang.Class.getMethods(Class.java:1410)
at com.sun.xml.ws.model.RuntimeModeler.determineWebMethodUse(RuntimeModeler.java:303)
at com.sun.xml.ws.model.RuntimeModeler.processClass(RuntimeModeler.java:319)
at com.sun.tools.ws.wscompile.WsgenTool.buildModel(WsgenTool.java:218)
at com.sun.tools.ws.wscompile.WsgenTool.run(WsgenTool.java:119)
at com.sun.tools.ws.util.WSToolsObjectFactoryImpl.wsgen(WSToolsObjectFactoryImpl.java:61)
at com.sun.tools.ws.spi.WSToolsObjectFactory.wsgen(WSToolsObjectFactory.java:107)
at com.sun.enterprise.webservice.WsUtil.runWsGen(WsUtil.java:1845)
at com.sun.enterprise.webservice.WsUtil.genWSInfo(WsUtil.java:2249)
at com.sun.enterprise.deployment.backend.ModuleDeployer.loadDescriptors(ModuleDeployer.java:424)
at com.sun.enterprise.deployment.backend.EjbModuleDeployer.deploy(EjbModuleDeployer.java:140)
at com.sun.enterprise.deployment.backend.ModuleDeployer.doRequestFinish(ModuleDeployer.java:179)
at com.sun.enterprise.deployment.phasing.J2EECPhase.runPhase(J2EECPhase.java:191)
at com.sun.enterprise.deployment.phasing.DeploymentPhase.executePhase(DeploymentPhase.java:108)
at com.sun.enterprise.deployment.phasing.PEDeploymentService.executePhases(PEDeploymentService.java:919)
at com.sun.enterprise.deployment.phasing.PEDeploymentService.deploy(PEDeploymentService.java:279)
at com.sun.enterprise.deployment.phasing.PEDeploymentService.deploy(PEDeploymentService.java:788)
at com.sun.enterprise.management.deploy.DeployThread.deploy(DeployThread.java:187)
at com.sun.enterprise.management.deploy.DeployThread.run(DeployThread.java:223)

Users with the same issue

Once, 1 month ago
Once, 9 months ago
6 times, 1 year ago
2 times, 1 year ago
2 times, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.