org.osgi.framework.BundleException: Could not resolve module: org.eclipse.tycho.p2.tools.impl [55] Unresolved requirement: Import-Package: org.eclipse.tycho.p2.impl.publisher -> Export-Package: org.eclipse.tycho.p2.impl.publisher; bundle-version="0.23.0.201503240816"; bundle-symbolic-name="org.eclipse.tycho.p2.resolver.impl"; version="0.0.0"; x-friends:="org.eclipse.tycho.p2.impl.test" org.eclipse.tycho.p2.resolver.impl [53] Unresolved requirement: Require-Bundle: org.eclipse.core.runtime -> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150316-1241"; singleton:="true" org.eclipse.core.runtime [9] Unresolved requirement: Require-Bundle: javax.annotation; bundle-version="1.1.0"; visibility:="reexport"; resolution:="optional" Unresolved requirement: Require-Bundle: javax.inject; bundle-version="1.0.0"; visibility:="reexport"; resolution:="optional" Unresolved requirement: Require-Bundle: org.eclipse.core.contenttype; bundle-version="[3.3.0,4.0.0)"; visibility:="reexport" -> Bundle-SymbolicName: org.eclipse.core.contenttype; bundle-version="3.4.200.v20150316-1243"; singleton:="true" org.eclipse.core.contenttype [5] Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

Eclipse Bugzilla | tobias.oberlies | 2 years ago
  1. 0

    Require Java 1.7 to run Tycho 0.23.0

    Eclipse Bugzilla | 2 years ago | tobias.oberlies
    org.osgi.framework.BundleException: Could not resolve module: org.eclipse.tycho.p2.tools.impl [55] Unresolved requirement: Import-Package: org.eclipse.tycho.p2.impl.publisher -> Export-Package: org.eclipse.tycho.p2.impl.publisher; bundle-version="0.23.0.201503240816"; bundle-symbolic-name="org.eclipse.tycho.p2.resolver.impl"; version="0.0.0"; x-friends:="org.eclipse.tycho.p2.impl.test" org.eclipse.tycho.p2.resolver.impl [53] Unresolved requirement: Require-Bundle: org.eclipse.core.runtime -> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150316-1241"; singleton:="true" org.eclipse.core.runtime [9] Unresolved requirement: Require-Bundle: javax.annotation; bundle-version="1.1.0"; visibility:="reexport"; resolution:="optional" Unresolved requirement: Require-Bundle: javax.inject; bundle-version="1.0.0"; visibility:="reexport"; resolution:="optional" Unresolved requirement: Require-Bundle: org.eclipse.core.contenttype; bundle-version="[3.3.0,4.0.0)"; visibility:="reexport" -> Bundle-SymbolicName: org.eclipse.core.contenttype; bundle-version="3.4.200.v20150316-1243"; singleton:="true" org.eclipse.core.contenttype [5] Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
  2. 0

    Fuse: Fix failing smoke tests on Windows (Luna)

    GitHub | 1 year ago | apodhrad
    org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.ui.macosx [183] Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"
  3. 0

    OSX: Fehler beim Start

    GitHub | 2 years ago | fmarczin
    org.osgi.framework.BundleException: Could not resolve module: name.abuchen.portfolio.ui [15] Unresolved requirement: Import-Package: name.abuchen.portfolio.checks -> Export-Package: name.abuchen.portfolio.checks; bundle-version="0.14.0"; bundle-symbolic-name="name.abuchen.portfolio"; version="0.0.0" name.abuchen.portfolio [14] Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    4DIAC IDE views

    fordiac | 2 years ago | niko87
    org.osgi.framework.BundleException: Could not resolve module: org.eclipse.gmf.runtime.diagram.ui.render [198] Unresolved requirement: Require-Bundle: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="[1.2.0,2.0.0)" -> Bundle-SymbolicName: org.eclipse.gmf.runtime.draw2d.ui.render.awt; bundle-version="1.8.0.201408201453"; singleton:="true" org.eclipse.gmf.runtime.draw2d.ui.render.awt [203] Unresolved requirement: Require-Bundle: org.apache.batik.ext.awt; bundle-version="[1.6.0,1.7.0)" -> Bundle-SymbolicName: org.apache.batik.ext.awt; bundle-version="1.6.0.v201011041432" org.apache.batik.ext.awt [17] Unresolved requirement: Require-Bundle: org.apache.batik.util; bundle-version="[1.6.0,1.7.0)"
  6. 0

    Chef eclipse cookbook and transitive dependencies for plugins

    Stack Overflow | 7 months ago | Farrukh Najmi
    org.osgi.framework.BundleException: Could not resolve module: org.eclipse.m2e.wtp [540] Unresolved requirement: Require-Bundle: org.eclipse.m2e.maven.runtime; bundle-version="[1.5.0,2.0.0)" -> Bundle-SymbolicName: org.eclipse.m2e.maven.runtime; bundle-version="1.6.2.20150902-0001"; singleton:="false" org.eclipse.m2e.maven.runtime [862] Unresolved requirement: Require-Bundle: org.eclipse.m2e.maven.runtime.slf4j.simple; bundle-version="[1.6.0,1.7.0)" -> Bundle-SymbolicName: org.eclipse.m2e.maven.runtime.slf4j.simple; bundle-version="1.6.2.20150902-0001"; singleton:="false" org.eclipse.m2e.maven.runtime.slf4j.simple [863] Unresolved requirement: Require-Capability: osgi.ee; filter:="(|(&(osgi.ee=JavaSE)(version=1.7))(&(osgi.ee=JavaSE)(version=1.8)))"

    46 unregistered visitors
    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. org.osgi.framework.BundleException

      Could not resolve module: org.eclipse.tycho.p2.tools.impl [55] Unresolved requirement: Import-Package: org.eclipse.tycho.p2.impl.publisher -> Export-Package: org.eclipse.tycho.p2.impl.publisher; bundle-version="0.23.0.201503240816"; bundle-symbolic-name="org.eclipse.tycho.p2.resolver.impl"; version="0.0.0"; x-friends:="org.eclipse.tycho.p2.impl.test" org.eclipse.tycho.p2.resolver.impl [53] Unresolved requirement: Require-Bundle: org.eclipse.core.runtime -> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150316-1241"; singleton:="true" org.eclipse.core.runtime [9] Unresolved requirement: Require-Bundle: javax.annotation; bundle-version="1.1.0"; visibility:="reexport"; resolution:="optional" Unresolved requirement: Require-Bundle: javax.inject; bundle-version="1.0.0"; visibility:="reexport"; resolution:="optional" Unresolved requirement: Require-Bundle: org.eclipse.core.contenttype; bundle-version="[3.3.0,4.0.0)"; visibility:="reexport" -> Bundle-SymbolicName: org.eclipse.core.contenttype; bundle-version="3.4.200.v20150316-1243"; singleton:="true" org.eclipse.core.contenttype [5] Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

      at org.eclipse.osgi.container.Module.start()
    2. Eclipse OSGi
      EventManager$EventThread.run
      1. org.eclipse.osgi.container.Module.start(Module.java:434)
      2. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
      3. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
      4. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
      5. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
      6. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
      7. org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
      8. org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
      8 frames