org.osgi.framework.BundleException: Could not resolve module: org.eclipse.rcptt.tesla.jface.text [162] Unresolved requirement: Require-Bundle: org.eclipse.rcptt.tesla.swt; bundle-version="[1.5.0,1.6.0)" -> Bundle-SymbolicName: org.eclipse.rcptt.tesla.swt; bundle-version="1.5.0.201406151156"; singleton:="true" org.eclipse.rcptt.tesla.swt [186] Unresolved requirement: Require-Bundle: org.eclipse.ui

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via eclipse.org by Unknown author, 1 year ago
Could not resolve module: org.eclipse.rcptt.tesla.jface.text [162] Unresolved requirement: Require-Bundle: org.eclipse.rcptt.tesla.swt; bundle-version="[1.5.0,1.6.0)" -> Bundle-SymbolicName: org.eclipse.rcptt.tesla.swt; bundle-version
via GitHub by dahbiahmed
, 1 year ago
Could not resolve module: com.jkiss.dbeaver.ent.mongodb [14] Unresolved requirement: Require-Bundle: org.eclipse.ui -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.107.0.v20150507-1945"; singleton:="true" org.eclipse.ui [88
via GitHub by laimaretto
, 1 year ago
Could not resolve module: org.jkiss.dbeaver.ext.oracle [90] Unresolved requirement: Require-Bundle: org.eclipse.ui -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.107.0.v20150507-1945"; singleton:="true" org.eclipse.ui [71
via GitHub by panhezeng
, 6 months ago
Could not resolve module: com.dbeaver.ent.base [6] Unresolved requirement: Require-Bundle: org.eclipse.ui -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.107.0.v20150507-1945"; singleton:="true" org.eclipse.ui [144
via Stack Overflow by TryingToCode
, 4 months ago
Could not resolve module: org.eclipse.ant.ui [57] Unresolved requirement: Require-Bundle: org.eclipse.ui.externaltools; bundle-version="[3.2.0,4.0.0)" Unresolved requirement: Require-Bundle: org.eclipse.ui.editors; bundle-version="[3.2.0,4.0.0
via talendforge.org by Unknown author, 1 year ago
Could not resolve module: org.talend.repository.antlride.ui [379] Unresolved requirement: Require-Bundle: org.talend.dataprofiler.core -> Bundle-SymbolicName: org.talend.dataprofiler.core; bundle-version= "6.0.0.20150217_0324-SNAPSHOT
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.rcptt.tesla.jface.text [162] Unresolved requirement: Require-Bundle: org.eclipse.rcptt.tesla.swt; bundle-version="[1.5.0,1.6.0)" -> Bundle-SymbolicName: org.eclipse.rcptt.tesla.swt; bundle-version="1.5.0.201406151156"; singleton:="true" org.eclipse.rcptt.tesla.swt [186] Unresolved requirement: Require-Bundle: org.eclipse.ui
at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
2 times, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
43 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.