org.osgi.framework.BundleException: Could not resolve module: org.eclipse.rcptt.tesla.recording.aspects.workbench.texteditor [176] Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via eclipse.org by Unknown author, 1 year ago
Could not resolve module: org.eclipse.rcptt.tesla.recording.aspects.workbench.texteditor [176] Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench
via GitHub by tarcisiojr
, 6 months ago
Could not resolve module: org.eclipse.ui [67] Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport" -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.107.1
via Stack Overflow by dexter
, 1 year ago
Could not resolve module: org.talend.repository.items.importexport.ui [15] Unresolved requirement: Require-Bundle: org.eclipse.ui -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.0.v20140812-1751"; singleton:="true
via Stack Overflow by NVG
, 1 year ago
Could not resolve module: org.eclipse.team.ui [1] Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"; resolution:="optional" -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.10.2
via GitHub by KevinPhemius
, 1 year ago
Could not resolve module: eu.netide.configuration.launcher [750] Unresolved requirement: Require-Bundle: org.eclipse.debug.ui; bundle-version="3.10.1"
via GitHub by elharo
, 1 year ago
Could not resolve module: com.google.cloud.tools.eclipse.appengine.localserver [1044] Unresolved requirement: Require-Bundle: com.google.cloud.tools.eclipse.appengine.ui; bundle-version="0.1.0"
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.rcptt.tesla.recording.aspects.workbench.texteditor [176] Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench
at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
43 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.