Pattern selector

Most relevant patterns first. Most helpful ones displayed. Click here to show all.

  1. EventManager$EventThread.run() has thrown a BundleException
    %systemBundle
    43
    90
    10
  2. EventManager.dispatchEvent() has thrown a BundleException
    %systemBundle
    43
    90
    10

Your stack trace compared to the selected pattern

Jump to solutionsExpand frames
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.rcptt.tesla.properties.view [166] Unresolved requirement: Require-Bundle: org.eclipse.rcptt.tesla.swt -> Bundle-SymbolicName: org.eclipse.rcptt.tesla.swt; bundle-version="1.5.0.201406151156"; singleton:="true" org.eclipse.rcptt.tesla.swt [186] Unresolved requirement: Require-Bundle: org.eclipse.ui
6 matching frames hidden
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

External results for this pattern (10)

  1. MI-LA01via GitHub6 days ago
    Could not resolve module: org.eclipse.compare.win32 [84] Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=win32)"
    Show stack trace
  2. Александр Гурьяновvia Google Groups1 week ago
    Could not resolve module: org.scala-ide.scala210.jars [265] Another singleton bundle selected: osgi.identity; osgi.identity="org.scala-ide.scala210.jars"; type="osgi.bundle"; version:Version="4.0.0.201411191622"; singleton:="true"
    Show stack trace
  3. Ragas13via GitHub4 weeks ago
    Could not resolve module: name.abuchen.portfolio.ui [13] Unresolved requirement: Require-Bundle: org.eclipse.ui.forms; bundle-version="3.7.101"
    Show stack trace
  4. robertwvia GitHub1 month ago
    Could not resolve module: org.openhab.binding.isy [218] Unresolved requirement: Import-Package: org.hamcrest.core; version="1.3.0"
    Show stack trace
  5. craighamvia GitHub1 month ago
    Could not resolve module: org.openhab.binding.isy [218] Unresolved requirement: Import-Package: org.hamcrest.core; version="1.3.0"
    Show stack trace
  6. craighamvia GitHub1 month ago
    Could not resolve module: org.openhab.binding.isy [218] Unresolved requirement: Import-Package: org.hamcrest.core; version="1.3.0"
    Show stack trace
  7. craighamvia GitHub1 month ago
    Could not resolve module: org.openhab.binding.isy [218] Unresolved requirement: Import-Package: org.hamcrest.core; version="1.3.0"
    Show stack trace
  8. craighamvia GitHub1 month ago
    Could not resolve module: org.openhab.binding.isy [217] Another singleton bundle selected: osgi.identity; osgi.identity="org.openhab.binding.isy"; type="osgi.bundle"; version:Version="2.1.0.201706091634"; singleton:="true"
    Show stack trace
  9. MMaierovia GitHub2 months ago
    Could not resolve module: org.apache.activemq.artemis [60] Unresolved requirement: Import-Package: org.apache.activemq.artemis.jdbc.store.drivers; version="[2.5.0,3.0.0)"; resolution:="optional" Unresolved requirement: Import-Package: org.apache.activemq.artemis.jdbc.store.file; version="[2.5.0,3.0.0)"; resolution:="optional" Unresolved requirement: Import-Package: org.apache.activemq.artemis.jdbc.store.journal; version="[2.5.0,3.0.0)"; resolution:="optional" Unresolved requirement: Import-Package: org.apache.activemq.artemis.jdbc.store.sql; version="[2.5.0,3.0.0)"; resolution:="optional" Unresolved requirement: Import-Package: org.apache.xpath; resolution:="optional" Unresolved requirement: Import-Package: org.apache.xpath.objects; resolution:="optional" Unresolved requirement: Import-Package: org.jboss.logmanager; resolution:="optional" Unresolved requirement: Import-Package: org.jgroups; version="[3.6.0,4.0.0)"; resolution:="optional" Unresolved requirement: Import-Package: org.jgroups.conf; version="[3.6.0,4.0.0)"; resolution:="optional" Unresolved requirement: Import-Package: io.netty.channel.kqueue; version="[4.1.0,5.0.0)" Unresolved requirement: Import-Package: io.netty.channel.epoll; version="[4.1.0,5.0.0)" -> Export-Package: io.netty.channel.epoll; bundle-symbolic-name="io.netty.transport-native-epoll"; bundle-version="4.1.22.Final"; version="4.1.22"; uses:="io.netty.buffer,io.netty.channel,io.netty.channel.socket,io.netty.channel.unix,io.netty.util.concurrent" io.netty.transport-native-epoll [7] Unresolved requirement: Import-Package: io.netty.channel.unix; version="[4.1.0,5.0.0)"
    Show stack trace
  10. odockalvia Eclipse Bugzilla2 months ago
    Could not resolve module: org.eclipse.linuxtools.docker.ui [493] Unresolved requirement: Require-Bundle: org.eclipse.linuxtools.docker.core; bundle-version="1.0.0" -> Bundle-SymbolicName: org.eclipse.linuxtools.docker.core; bundle-version="4.1.0.201808032200"; singleton:="true" org.eclipse.linuxtools.docker.core [490] Unresolved requirement: Require-Bundle: com.github.jnr.unixsocket; bundle-version="0.4.0" -> Bundle-SymbolicName: com.github.jnr.unixsocket; bundle-version="0.18.0.v20180207-1730" com.github.jnr.unixsocket [15] Unresolved requirement: Require-Bundle: com.github.jnr.ffi -> Bundle-SymbolicName: com.github.jnr.ffi; bundle-version="2.1.4.v20180207-1730" com.github.jnr.ffi [11] Unresolved requirement: Import-Package: org.objectweb.asm; version="5.0.1" -> Export-Package: org.objectweb.asm; bundle-symbolic-name="org.objectweb.asm"; bundle-version="6.2.0.v20180723-2102"; version="6.2.0" org.objectweb.asm [1021] Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=9.0))" Unresolved requirement: Import-Package: org.objectweb.asm.util; version="5.0.1" -> Export-Package: org.objectweb.asm.util; bundle-symbolic-name="org.objectweb.asm.util"; bundle-version="6.2.0.v20180723-2102"; version="6.2.0"; uses:="org.objectweb.asm,org.objectweb.asm.signature" org.objectweb.asm.util [1025] Unresolved requirement: Import-Package: org.objectweb.asm; version="6.2.0" -> Export-Package: org.objectweb.asm; bundle-symbolic-name="org.objectweb.asm"; bundle-version="6.2.0.v20180723-2102"; version="6.2.0" Unresolved requirement: Import-Package: jnr.ffi.byref; version="2.1.4" -> Export-Package: jnr.ffi.byref; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi" Unresolved requirement: Import-Package: jnr.ffi.annotations; version="2.1.4" -> Export-Package: jnr.ffi.annotations; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi" Unresolved requirement: Import-Package: jnr.ffi.types; version="2.1.4" -> Export-Package: jnr.ffi.types; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi,jnr.ffi.annotations" Unresolved requirement: Import-Package: jnr.enxio.channels; version="0.16.0" -> Export-Package: jnr.enxio.channels; bundle-symbolic-name="com.github.jnr.enxio"; bundle-version="0.16.0.v20180207-1730"; version="0.16.0"; uses:="jnr.constants.platform,jnr.ffi,jnr.ffi.annotations,jnr.ffi.types" com.github.jnr.enxio [10] Unresolved requirement: Import-Package: jnr.ffi.types; version="2.1.4" -> Export-Package: jnr.ffi.types; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi,jnr.ffi.annotations" Unresolved requirement: Import-Package: jnr.ffi.annotations; version="2.1.4" -> Export-Package: jnr.ffi.annotations; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi" Unresolved requirement: Import-Package: jnr.ffi.provider.jffi; version="2.1.4" -> Export-Package: jnr.ffi.provider.jffi; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="com.kenai.jffi,jnr.ffi,jnr.ffi.mapper,jnr.ffi.provider,jnr.ffi.types,org.objectweb.asm" Unresolved requirement: Import-Package: jnr.ffi; version="2.1.4" -> Export-Package: jnr.ffi; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi.mapper,jnr.ffi.provider,jnr.ffi.util" Unresolved requirement: Require-Bundle: com.github.jnr.ffi -> Bundle-SymbolicName: com.github.jnr.ffi; bundle-version="2.1.4.v20180207-1730" Unresolved requirement: Import-Package: jnr.posix; version="3.0.35" -> Export-Package: jnr.posix; bundle-symbolic-name="com.github.jnr.posix"; bundle-version="3.0.35.v20180207-1730"; version="3.0.35"; uses:="jnr.constants,jnr.constants.platform,jnr.ffi,jnr.ffi.annotations,jnr.ffi.byref,jnr.ffi.mapper,jnr.ffi.types,jnr.posix.util,jnr.posix.windows" com.github.jnr.posix [14] Unresolved requirement: Import-Package: sun.misc; resolution:="optional" Unresolved requirement: Import-Package: jnr.ffi.byref; version="2.1.4" -> Export-Package: jnr.ffi.byref; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi" Unresolved requirement: Import-Package: jnr.ffi.mapper; version="2.1.4" -> Export-Package: jnr.ffi.mapper; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi" Unresolved requirement: Import-Package: jnr.ffi; version="2.1.4" -> Export-Package: jnr.ffi; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi.mapper,jnr.ffi.provider,jnr.ffi.util" Unresolved requirement: Import-Package: jnr.ffi.provider; version="2.1.4" -> Export-Package: jnr.ffi.provider; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi,jnr.ffi.mapper" Unresolved requirement: Import-Package: jnr.ffi.annotations; version="2.1.4" -> Export-Package: jnr.ffi.annotations; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi" Unresolved requirement: Import-Package: jnr.ffi.types; version="2.1.4" -> Export-Package: jnr.ffi.types; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi,jnr.ffi.annotations" Unresolved requirement: Import-Package: jnr.ffi; version="2.1.4" -> Export-Package: jnr.ffi; bundle-symbolic-name="com.github.jnr.ffi"; bundle-version="2.1.4.v20180207-1730"; version="2.1.4"; uses:="jnr.ffi.mapper,jnr.ffi.provider,jnr.ffi.util" Unresolved requirement: Require-Bundle: com.spotify.docker.client; bundle-version="[8.9.2,9.0.0)" -> Bundle-SymbolicName: com.spotify.docker.client; bundle-version="8.9.2.v20180207-1730" com.spotify.docker.client [35] Unresolved requirement: Import-Package: com.google.api.client.util; resolution:="optional" Unresolved requirement: Import-Package: com.google.auth.oauth2; resolution:="optional" Unresolved requirement: Import-Package: jnr.unixsocket; version="0.8.0" -> Export-Package: jnr.unixsocket; bundle-symbolic-name="com.github.jnr.unixsocket"; bundle-version="0.18.0.v20180207-1730"; version="0.18.0"; uses:="jnr.enxio.channels,jnr.ffi.annotations,jnr.ffi.byref,jnr.ffi.types,jnr.posix" Unresolved requirement: Require-Bundle: com.github.jnr.enxio; bundle-version="0.5.0" -> Bundle-SymbolicName: com.github.jnr.enxio; bundle-version="0.16.0.v20180207-1730" Unresolved requirement: Require-Bundle: com.spotify.docker.client; bundle-version="3.6.8" -> Bundle-SymbolicName: com.spotify.docker.client; bundle-version="8.9.2.v20180207-1730"
    Show stack trace