org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource org.fusesource.ide.branding [osgi.identity; osgi.identity="org.fusesource.ide.branding"; type="osgi.bundle"; version:Version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true"] because it is exposed to package 'javax.xml.bind.annotation.adapters' from resources org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] and javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"] via two dependency chains. Chain 1: org.fusesource.ide.branding [osgi.identity; osgi.identity="org.fusesource.ide.branding"; type="osgi.bundle"; version:Version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true"] require: (osgi.wiring.bundle=org.eclipse.core.runtime) | provide: osgi.wiring.bundle: org.eclipse.core.runtime org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] Chain 2: org.fusesource.ide.branding [osgi.identity; osgi.identity="org.fusesource.ide.branding"; type="osgi.bundle"; version:Version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true"] import: (osgi.wiring.package=org.fusesource.camel.tooling.util) | export: osgi.wiring.package=org.fusesource.camel.tooling.util; uses:=org.apache.camel.model io.fabric8.camel-tooling-util [osgi.identity; osgi.identity="io.fabric8.camel-tooling-util"; type="osgi.bundle"; version:Version="1.0.0.redhat-379"] import: (&(osgi.wiring.package=org.apache.camel.model)(&(version>=2.12.0)(!(version>=3.0.0)))) | export: osgi.wiring.package=org.apache.camel.model; uses:=javax.xml.bind.annotation.adapters org.apache.camel.camel-core [osgi.identity; osgi.identity="org.apache.camel.camel-core"; type="osgi.bundle"; version:Version="2.12.0.redhat-610379"] import: (osgi.wiring.package=javax.xml.bind.annotation.adapters) | export: osgi.wiring.package: javax.xml.bind.annotation.adapters javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"]

JBoss Issue Tracker | Paul Leacu | 2 years ago
  1. 0

    If I run eclipse/jbdevstudio -clean (purging the OSGi cache) I don't get this error. SESSION 2014-07-30 09:22:59.386 ----------------------------------------------- eclipse.buildId=unknown java.version=1.7.0_60-ea java.vendor=Oracle Corporation BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US Framework arguments: -product com.jboss.devstudio.core.product Command-line arguments: -os linux -ws gtk -arch x86_64 -product com.jboss.devstudio.core.product !ENTRY org.fusesource.ide.branding 4 0 2014-07-30 09:23:05.987 !MESSAGE FrameworkEvent ERROR !STACK 0 org.osgi.framework.BundleException: Could not resolve module: org.fusesource.ide.branding [975] Unresolved requirement: Require-Bundle: org.fusesource.ide.camel.model -> Bundle-SymbolicName: org.fusesource.ide.camel.model; bundle-version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true" org.fusesource.ide.camel.model [977] No resolution report for the bundle. Bundle was not resolved because of a uses contraint violation. org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource org.fusesource.ide.branding [osgi.identity; osgi.identity="org.fusesource.ide.branding"; type="osgi.bundle"; version:Version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true"] because it is exposed to package 'javax.xml.bind.annotation.adapters' from resources org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] and javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"] via two dependency chains. Chain 1: org.fusesource.ide.branding [osgi.identity; osgi.identity="org.fusesource.ide.branding"; type="osgi.bundle"; version:Version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true"] require: (osgi.wiring.bundle=org.eclipse.core.runtime) | provide: osgi.wiring.bundle: org.eclipse.core.runtime org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] Chain 2: org.fusesource.ide.branding [osgi.identity; osgi.identity="org.fusesource.ide.branding"; type="osgi.bundle"; version:Version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true"] import: (osgi.wiring.package=org.fusesource.camel.tooling.util) | export: osgi.wiring.package=org.fusesource.camel.tooling.util; uses:=org.apache.camel.model io.fabric8.camel-tooling-util [osgi.identity; osgi.identity="io.fabric8.camel-tooling-util"; type="osgi.bundle"; version:Version="1.0.0.redhat-379"] import: (&(osgi.wiring.package=org.apache.camel.model)(&(version>=2.12.0)(!(version>=3.0.0)))) | export: osgi.wiring.package=org.apache.camel.model; uses:=javax.xml.bind.annotation.adapters org.apache.camel.camel-core [osgi.identity; osgi.identity="org.apache.camel.camel-core"; type="osgi.bundle"; version:Version="2.12.0.redhat-610379"] import: (osgi.wiring.package=javax.xml.bind.annotation.adapters) | export: osgi.wiring.package: javax.xml.bind.annotation.adapters javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"] at org.eclipse.osgi.container.Module.start(Module.java:434) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1) at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230) at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

    JBoss Issue Tracker | 2 years ago | Paul Leacu
    org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource org.fusesource.ide.branding [osgi.identity; osgi.identity="org.fusesource.ide.branding"; type="osgi.bundle"; version:Version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true"] because it is exposed to package 'javax.xml.bind.annotation.adapters' from resources org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] and javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"] via two dependency chains. Chain 1: org.fusesource.ide.branding [osgi.identity; osgi.identity="org.fusesource.ide.branding"; type="osgi.bundle"; version:Version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true"] require: (osgi.wiring.bundle=org.eclipse.core.runtime) | provide: osgi.wiring.bundle: org.eclipse.core.runtime org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] Chain 2: org.fusesource.ide.branding [osgi.identity; osgi.identity="org.fusesource.ide.branding"; type="osgi.bundle"; version:Version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true"] import: (osgi.wiring.package=org.fusesource.camel.tooling.util) | export: osgi.wiring.package=org.fusesource.camel.tooling.util; uses:=org.apache.camel.model io.fabric8.camel-tooling-util [osgi.identity; osgi.identity="io.fabric8.camel-tooling-util"; type="osgi.bundle"; version:Version="1.0.0.redhat-379"] import: (&(osgi.wiring.package=org.apache.camel.model)(&(version>=2.12.0)(!(version>=3.0.0)))) | export: osgi.wiring.package=org.apache.camel.model; uses:=javax.xml.bind.annotation.adapters org.apache.camel.camel-core [osgi.identity; osgi.identity="org.apache.camel.camel-core"; type="osgi.bundle"; version:Version="2.12.0.redhat-610379"] import: (osgi.wiring.package=javax.xml.bind.annotation.adapters) | export: osgi.wiring.package: javax.xml.bind.annotation.adapters javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"]
  2. 0

    Eclipse Community Forums: Newcomers ยป [SOLVED]error while opening eclipse Luna

    eclipse.org | 2 months ago
    org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource org.eclipse.jpt.dbws.eclipselink.ui [osgi.identity; osgi.identity="org.eclipse.jpt.dbws.eclipselink.ui"; type="osgi.bundle"; version:Version="1.1.100.v201310142259"; singleton:="true"] because it is exposed to package 'javax.xml.bind' from resources org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] and javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"] via two dependency chains. Chain 1: org.eclipse.jpt.dbws.eclipselink.ui [osgi.identity; osgi.identity="org.eclipse.jpt.dbws.eclipselink.ui"; type="osgi.bundle"; version:Version="1.1.100.v201310142259"; singleton:="true"] require: (&(osgi.wiring.bundle=org.eclipse.wst.common.project.facet.ui)(&(bundle-version>=1.3.0)(!(bundle-version>=2.0.0)))) | provide: osgi.wiring.bundle: org.eclipse.wst.common.project.facet.ui org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] Chain 2: org.eclipse.jpt.dbws.eclipselink.ui [osgi.identity; osgi.identity="org.eclipse.jpt.dbws.eclipselink.ui"; type="osgi.bundle"; version:Version="1.1.100.v201310142259"; singleton:="true"] require: (&(osgi.wiring.bundle=org.eclipse.persistence.dbws.builder)(&(bundle-version>=2.3.0)(!(bundle-version>=3.0.0)))) | provide: osgi.wiring.bundle; osgi.wiring.bundle="org.eclipse.persistence.dbws.builder"; bundle-version:Version="2.6.0.v20130815-a4708b6" org.eclipse.persistence.dbws.builder [osgi.identity; osgi.identity="org.eclipse.persistence.dbws.builder"; type="osgi.bundle"; version:Version="2.6.0.v20130815-a4708b6"] import: (osgi.wiring.package=javax.xml.bind) | export: osgi.wiring.package: javax.xml.bind javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"]
  3. 0

    I get this in the error log. No idea what 'damage' this does, but it seems worrysome. {code} eclipse.buildId=3.6.0.201406240433-CI-B1925759-e44 java.version=1.7.0_60 java.vendor=Oracle Corporation BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA Framework arguments: -product org.springsource.ggts.ide -groovy.compiler.level 23 Command-line arguments: -os linux -ws gtk -arch x86_64 -product org.springsource.ggts.ide -groovy.compiler.level 23 org.eclipse.jpt.dbws.eclipselink.ui Error Wed Jun 25 14:38:54 PDT 2014 FrameworkEvent ERROR org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jpt.dbws.eclipselink.ui [447] Bundle was not resolved because of a uses contraint violation. org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource org.eclipse.jpt.dbws.eclipselink.ui [osgi.identity; osgi.identity="org.eclipse.jpt.dbws.eclipselink.ui"; type="osgi.bundle"; version:Version="1.1.100.v201310142259"; singleton:="true"] because it is exposed to package 'javax.xml.bind' from resources org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] and javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"] via two dependency chains. Chain 1: org.eclipse.jpt.dbws.eclipselink.ui [osgi.identity; osgi.identity="org.eclipse.jpt.dbws.eclipselink.ui"; type="osgi.bundle"; version:Version="1.1.100.v201310142259"; singleton:="true"] require: (&(osgi.wiring.bundle=org.eclipse.wst.common.project.facet.ui)(&(bundle-version>=1.3.0)(!(bundle-version>=2.0.0)))) | provide: osgi.wiring.bundle: org.eclipse.wst.common.project.facet.ui org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] Chain 2: org.eclipse.jpt.dbws.eclipselink.ui [osgi.identity; osgi.identity="org.eclipse.jpt.dbws.eclipselink.ui"; type="osgi.bundle"; version:Version="1.1.100.v201310142259"; singleton:="true"] require: (&(osgi.wiring.bundle=org.eclipse.persistence.dbws.builder)(&(bundle-version>=2.3.0)(!(bundle-version>=3.0.0)))) | provide: osgi.wiring.bundle; osgi.wiring.bundle="org.eclipse.persistence.dbws.builder"; bundle-version:Version="2.6.0.v20130815-a4708b6" org.eclipse.persistence.dbws.builder [osgi.identity; osgi.identity="org.eclipse.persistence.dbws.builder"; type="osgi.bundle"; version:Version="2.6.0.v20130815-a4708b6"] import: (osgi.wiring.package=javax.xml.bind) | export: osgi.wiring.package: javax.xml.bind javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"] at org.eclipse.osgi.container.Module.start(Module.java:434) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1) at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230) at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340) {code}

    SpringSource Issue Tracker | 2 years ago | Kris De Volder (c)
    org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource org.eclipse.jpt.dbws.eclipselink.ui [osgi.identity; osgi.identity="org.eclipse.jpt.dbws.eclipselink.ui"; type="osgi.bundle"; version:Version="1.1.100.v201310142259"; singleton:="true"] because it is exposed to package 'javax.xml.bind' from resources org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] and javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"] via two dependency chains. Chain 1: org.eclipse.jpt.dbws.eclipselink.ui [osgi.identity; osgi.identity="org.eclipse.jpt.dbws.eclipselink.ui"; type="osgi.bundle"; version:Version="1.1.100.v201310142259"; singleton:="true"] require: (&(osgi.wiring.bundle=org.eclipse.wst.common.project.facet.ui)(&(bundle-version>=1.3.0)(!(bundle-version>=2.0.0)))) | provide: osgi.wiring.bundle: org.eclipse.wst.common.project.facet.ui org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] Chain 2: org.eclipse.jpt.dbws.eclipselink.ui [osgi.identity; osgi.identity="org.eclipse.jpt.dbws.eclipselink.ui"; type="osgi.bundle"; version:Version="1.1.100.v201310142259"; singleton:="true"] require: (&(osgi.wiring.bundle=org.eclipse.persistence.dbws.builder)(&(bundle-version>=2.3.0)(!(bundle-version>=3.0.0)))) | provide: osgi.wiring.bundle; osgi.wiring.bundle="org.eclipse.persistence.dbws.builder"; bundle-version:Version="2.6.0.v20130815-a4708b6" org.eclipse.persistence.dbws.builder [osgi.identity; osgi.identity="org.eclipse.persistence.dbws.builder"; type="osgi.bundle"; version:Version="2.6.0.v20130815-a4708b6"] import: (osgi.wiring.package=javax.xml.bind) | export: osgi.wiring.package: javax.xml.bind javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"]
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Drools 6.4.1 Eclipse upgrade breaks Drools Eclipse plugins

    Google Groups | 1 month ago | Webster Homer
    org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource org.eclipse.egit.ui [osgi.identity; osgi.identity="org.eclipse.egit.ui"; type="osgi.bundle"; version:Version="4.4.1.201607150455-r"; singleton:="true"] because it is exposed to package 'org.eclipse.jgit.transport' from resources org.eclipse.jgit [osgi.identity; osgi.identity="org.eclipse.jgit"; type="osgi.bundle"; version:Version="4.4.1.201607150455-r"] and org.eclipse.jgit [osgi.identity; osgi.identity="org.eclipse.jgit"; type="osgi.bundle"; version:Version="4.1.1.201511131810-r"] via two dependency chains. Chain 1: org.eclipse.egit.ui [osgi.identity; osgi.identity="org.eclipse.egit.ui"; type="osgi.bundle"; version:Version="4.4.1.201607150455-r"; singleton:="true"] import: (&(osgi.wiring.package=org.eclipse.jgit.transport)(&(version>=4.4.1)(!(version>=4.5.0)))) | export: osgi.wiring.package: org.eclipse.jgit.transport org.eclipse.jgit [osgi.identity; osgi.identity="org.eclipse.jgit"; type="osgi.bundle"; version:Version="4.4.1.201607150455-r"] Chain 2: org.eclipse.egit.ui [osgi.identity; osgi.identity="org.eclipse.egit.ui"; type="osgi.bundle"; version:Version="4.4.1.201607150455-r"; singleton:="true"] require: (&(osgi.wiring.bundle=org.eclipse.jgit)(&(bundle-version>=4.1.0)(!(bundle-version>=4.2.0)))) | provide: osgi.wiring.bundle: org.eclipse.jgit org.eclipse.jgit [osgi.identity; osgi.identity="org.eclipse.jgit"; type="osgi.bundle"; version:Version="4.1.1.201511131810-r"]
  6. 0

    Bundle was not resolved because of a uses contraint violation

    Stack Overflow | 2 weeks ago | ekjcfn3902039
    org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource My3rdPartyLib.my3rdPartyLib_api [osgi.identity; osgi.identity="My3rdPartyLib.my3rdPartyLib_api"; type="osgi.bundle"; version:Version="2.4"] because it is exposed to package 'org.slf4j' from resources slf4j.api [osgi.identity; osgi.identity="slf4j.api"; type="osgi.bundle"; version:Version="1.7.21"] and activemq-all [osgi.identity; osgi.identity="activemq-all"; type="osgi.bundle"; version:Version="5.9.0"] via two dependency chains. Chain 1: My3rdPartyLib.my3rdPartyLib_api [osgi.identity; osgi.identity="My3rdPartyLib.my3rdPartyLib_api"; type="osgi.bundle"; version:Version="2.4"] import: (osgi.wiring.package=org.slf4j) | export: osgi.wiring.package: org.slf4j slf4j.api [osgi.identity; osgi.identity="slf4j.api"; type="osgi.bundle"; version:Version="1.7.21"] Chain 2: My3rdPartyLib.my3rdPartyLib_api [osgi.identity; osgi.identity="My3rdPartyLib.my3rdPartyLib_api"; type="osgi.bundle"; version:Version="2.4"] import: (osgi.wiring.package=org.apache.activemq) | export: osgi.wiring.package: org.apache.activemq; uses:=org.slf4j export: osgi.wiring.package=org.slf4j activemq-all [osgi.identity; osgi.identity="activemq-all"; type="osgi.bundle"; version:Version="5.9.0"]

    1 unregistered visitors
    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. org.osgi.service.resolver.ResolutionException

      Uses constraint violation. Unable to resolve resource org.fusesource.ide.branding [osgi.identity; osgi.identity="org.fusesource.ide.branding"; type="osgi.bundle"; version:Version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true"] because it is exposed to package 'javax.xml.bind.annotation.adapters' from resources org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] and javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"] via two dependency chains. Chain 1: org.fusesource.ide.branding [osgi.identity; osgi.identity="org.fusesource.ide.branding"; type="osgi.bundle"; version:Version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true"] require: (osgi.wiring.bundle=org.eclipse.core.runtime) | provide: osgi.wiring.bundle: org.eclipse.core.runtime org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.10.0.v20140606-1445"; singleton:="true"] Chain 2: org.fusesource.ide.branding [osgi.identity; osgi.identity="org.fusesource.ide.branding"; type="osgi.bundle"; version:Version="7.3.0.v20140729-2156-H292-MASTER"; singleton:="true"] import: (osgi.wiring.package=org.fusesource.camel.tooling.util) | export: osgi.wiring.package=org.fusesource.camel.tooling.util; uses:=org.apache.camel.model io.fabric8.camel-tooling-util [osgi.identity; osgi.identity="io.fabric8.camel-tooling-util"; type="osgi.bundle"; version:Version="1.0.0.redhat-379"] import: (&(osgi.wiring.package=org.apache.camel.model)(&(version>=2.12.0)(!(version>=3.0.0)))) | export: osgi.wiring.package=org.apache.camel.model; uses:=javax.xml.bind.annotation.adapters org.apache.camel.camel-core [osgi.identity; osgi.identity="org.apache.camel.camel-core"; type="osgi.bundle"; version:Version="2.12.0.redhat-610379"] import: (osgi.wiring.package=javax.xml.bind.annotation.adapters) | export: osgi.wiring.package: javax.xml.bind.annotation.adapters javax.xml.bind [osgi.identity; osgi.identity="javax.xml.bind"; type="osgi.bundle"; version:Version="2.1.9.v201005080401"]

      at org.eclipse.osgi.container.Module.start()
    2. Eclipse OSGi
      EventManager$EventThread.run
      1. org.eclipse.osgi.container.Module.start(Module.java:434)
      2. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
      3. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
      4. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
      5. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
      6. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
      7. org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
      8. org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
      8 frames