org.osgi.framework.BundleException: Unresolved constraint in bundle uk.org.cse.s mash.smash-core [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wirin g.package; (osgi.wiring.package=com.jamesmurty.utils)

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via felix-users by Tom Wilcox, 1 year ago
Unresolved constraint in bundle uk.org.cse.s mash.smash-core [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wirin g.package; (osgi.wiring.package=com.jamesmurty.utils)
via GitHub by pires
, 2 years ago
Unresolved constraint in bundle org.apache.aries.blueprint.core [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)
via gmane.org by Unknown author, 1 year ago
Unresolved constraint in bundle org.apache.aries.util [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0))))
via GitHub by deklanowski
, 2 years ago
Unresolved constraint in bundle org.ops4j.pax.swissbox.extender [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve 6.0: missing requirement [6.0] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
via hivmr.com by Unknown author, 1 year ago
Unresolved constraint in bundle org.apache.aries.proxy.api [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.util.nls)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve
via Google Groups by Unknown author, 4 months ago
Unresolved constraint in bundle org.apache.karaf.shell.log [13]: Unable to resolve 1 3.0: missing requirement [13.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.1 0.0)(!(version>=1.0.0))) [caused by: Unable to resolve 11.0: missing requirement [11.0] osgi.wiring.package; (osgi.wirin g.package=javax.security.auth)]
org.osgi.framework.BundleException: Unresolved constraint in bundle uk.org.cse.s mash.smash-core [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wirin g.package; (osgi.wiring.package=com.jamesmurty.utils)
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
at java.lang.Thread.run(Thread.java:722)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
14 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.