Pattern selector

Most relevant patterns first. Most helpful ones displayed. Click here to show all.

  1. Thread.run() has thrown a BundleException
    Java Runtime
    43
    51
    17
  2. FrameworkStartLevelImpl.run() has thrown a BundleException
    Apache Felix Main
    45
    53
    17

Your stack trace compared to the selected pattern

Jump to solutionsExpand frames
org.osgi.framework.BundleException: Unresolved constraint in bundle jaxb-api [2]: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wiring.package=javax.activation)
3 matching frames hidden
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
    at java.lang.Thread.run(Thread.java:724)

External results for this pattern (10)

  1. DanielAriasvia servicemix-users1 month ago
    Uses constraint violation. Unable to resolve bundle revision Obranza [309.0] because it exports package 'org.springframework .util.comparator' and is also exposed to it from bundle revision org.apache.serv icemix.bundles.spring-core [101.0] via the following dependency chain: Obranza [309.0] import: (osgi.wiring.package=org.springframework.osgi.context) | export: osgi.wiring.package=org.springframework.osgi.context; uses:=org.spri ngframework.beans org.springframework.osgi.core [109.0] import: (&(osgi.wiring.package=org.springframework.beans)(version>=2.5.6)(!( version>=4.0.0))) | export: osgi.wiring.package=org.springframework.beans; uses:=org.springframe work.core.io.support org.apache.servicemix.bundles.spring-beans [103.0] import: (&(osgi.wiring.package=org.springframework.core.io.support)(version> =3.2.17.RELEASE)(!(version>=3.3.0))) | export: osgi.wiring.package=org.springframework.core.io.support; uses:=org.s pringframework.util.comparator export: osgi.wiring.package=org.springframework.util.comparator org.apache.servicemix.bundles.spring-core [101.0]
    Show stack trace
  2. DanielAriasvia servicemix-users1 month ago
    Uses constraint violation. Unable to resolve bundle revision Obranza [309.0] because it exports package 'org.springframework .util.comparator' and is also exposed to it from bundle revision org.apache.serv icemix.bundles.spring-core [101.0] via the following dependency chain: Obranza [309.0] import: (osgi.wiring.package=org.springframework.osgi.context) | export: osgi.wiring.package=org.springframework.osgi.context; uses:=org.spri ngframework.beans org.springframework.osgi.core [109.0] import: (&(osgi.wiring.package=org.springframework.beans)(version>=2.5.6)(!( version>=4.0.0))) | export: osgi.wiring.package=org.springframework.beans; uses:=org.springframe work.core.io.support org.apache.servicemix.bundles.spring-beans [103.0] import: (&(osgi.wiring.package=org.springframework.core.io.support)(version> =3.2.17.RELEASE)(!(version>=3.3.0))) | export: osgi.wiring.package=org.springframework.core.io.support; uses:=org.s pringframework.util.comparator export: osgi.wiring.package=org.springframework.util.comparator org.apache.servicemix.bundles.spring-core [101.0]
    Show stack trace
  3. Ydvoidvia GitHub2 months ago
    Unresolved constraint in bundle org.ops4j.pax.url.mvn [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.spi)(version>=1.6.0)(!(version>=2.0.0)))
    Show stack trace
  4. Ydvoidvia GitHub2 months ago
    Unresolved constraint in bundle meta-inject-plugin [66]: Unable to resolve 66.0: missing requirement [66.0] osgi.wiring.package; (osgi.wiring.package=org.pentaho.di.core)
    Show stack trace
  5. Neo110via GitHub2 months ago
    Unable to resolve com.neva.felix.webconsole.plugins.search [7](R 7.0): missing requirement [com.neva.felix.webconsole.plugins.search [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) Unresolved requirements: [[com.neva.felix.webconsole.plugins.search [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))]
    Show stack trace
  6. rsgoncalvesvia GitHub2 months ago
    Unresolved constraint in bundle org.semanticweb.elk [26]: Unable to resolve 26.0: missing requirement [26.0] osgi.wiring.package; (&(osgi.wiring.package=org.liveontologies.puli)(version>=0.1.0)(!(version>=1.0.0)))
    Show stack trace
  7. GurjapSinghvia GitHub3 months ago
    Unresolved constraint in bundle org.semanticweb.owl.owlapi [12]: Unable to resolve 12.0: missing requirement [12.0] osgi.wiring.package; (osgi.wiring.package=com.github.benmanes.caffeine.cache)
    Show stack trace
  8. jpdigitalvia GitHub3 months ago
    Unresolved constraint in bundle openllet-protege [45]: Unable to resolve 45.0: missing requirement [45.0] osgi.wiring.bundle; (&(osgi.wiring.bundle=org.semanticweb.owl.owlapi)(bundle-version>=5.1.0))
    Show stack trace
  9. msfbrasilvia Stack Overflow3 months ago
    Unable to resolve br.com.mycompany.myapplication.api.log.listener.application-log-listener [41](R 41.0): missing requirement [br.com.mycompany.myapplication.api.log.listener.application-log-listener [41](R 41.0)] osgi.wiring.package; (osgi.wiring.package=br.com.mycompany.idpclient.model) Unresolved requirements: [[br.com.mycompany.myapplication.api.log.listener.application-log-listener [41](R 41.0)] osgi.wiring.package; (osgi.wiring.package=br.com.mycompany.idpclient.model)]
    Show stack trace
  10. Unresolved constraint in bundle org.apache.activemq.activemq-camel [349]: Unable to resolve 349.0: missing requirement [349.0] osgi.wi &(osgi.wiring.package=javax.jms)(version>=1.1.0)(!(version>=2.0.0)))
    Show stack trace