org.apache.commons.logging.LogConfigurationException: User-specified log class 'org.apache.commons.logging.impl.Log4JLogger' cannot be found or is not useable.

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Google Groups by Falzone, Chris, 5 months ago
User-specified log class 'org.apache.commons.logging.impl.Log4JLogger' cannot be found or is not useable.
via Stack Overflow by arjun
, 2 years ago
User-specified log class 'org.apache.commons.logging.impl.Log4JLogger' cannot be found or is not useable.
via Stack Overflow by Debajyoti Roy
, 1 year ago
User-specified log class 'org.apache.commons.logging.impl.Log4JLogger' cannot be found or is not useable.
via Stack Overflow by João Simas
, 2 years ago
User-specified log class 'org.apache.commons.logging.impl.Log4JLogger' cannot be found or is not useable.
via Oracle Community by kyroger, 1 year ago
User-specified log class 'org.apache.commons.logging.impl.Log4JLogger' cannot be found or is no t useable.
via Google Groups by t...@praqma.net (JIRA), 1 year ago
User-specified log class 'org.apache.commons.logging.impl.LogKitLogger' cannot be found or is not useable.
org.apache.commons.logging.LogConfigurationException: User-specified log class 'org.apache.commons.logging.impl.Log4JLogger' cannot be found or is not useable.
at org.apache.commons.logging.impl.LogFactoryImpl.discoverLogImplementation(LogFactoryImpl.java:804)
at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:541)
at org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.java:292)
at org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.java:269)
at com.aquent.ws.JobPostingServiceClient.(JobPostingServiceClient.java:8)
at com.aquent.osgi.AquentActivator.start(AquentActivator.java:92)
at com.dotcms.repackage.org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:645)
at com.dotcms.repackage.org.apache.felix.framework.Felix.activateBundle(Felix.java:2146)
at com.dotcms.repackage.org.apache.felix.framework.Felix.startBundle(Felix.java:2064)
at com.dotcms.repackage.org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1483)
at com.dotcms.repackage.org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:334)
at java.lang.Thread.run(Thread.java:745)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago

Know the solutions? Share your knowledge to help other developers to debug faster.