java.net.UnknownHostException

tip

Check if you don't have a VPN or something like this messing with your connection. Also, check Jenkins DNS configurations (try to start it with "--dns 8.8.8.8".

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • IDE 1.6.4 is now available for download
    via by Unknown author,
  • Problem with SMP lookup
    via GitHub by oskaremil
    ,
  • Minecraft Galaxy
    via by Unknown author,
  • JMeter - User - Recorded server name problem
    via by Unknown author,
  • java.net.UnknownHostException - Jsoup
    via Stack Overflow by Sachin
    ,
    • java.net.UnknownHostException: jeremylong.github.io at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:208) at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:176) at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:402) at java.net.Socket.connect(Socket.java:590) at sun.net.NetworkClient.doConnect(NetworkClient.java:187) at sun.net.www.http.HttpClient.openServer(HttpClient.java:417) at sun.net.www.http.HttpClient.openServer(HttpClient.java:512) at sun.net.www.http.HttpClient.<init>(HttpClient.java:227) at sun.net.www.http.HttpClient.New(HttpClient.java:320) at sun.net.www.http.HttpClient.New(HttpClient.java:336) at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:1004) at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:940) at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:858) at org.owasp.dependencycheck.data.update.EngineVersionCheck.getCurrentReleaseVersion(EngineVersionCheck.java:214) at org.owasp.dependencycheck.data.update.EngineVersionCheck.shouldUpdate(EngineVersionCheck.java:148) at org.owasp.dependencycheck.data.update.EngineVersionCheck.update(EngineVersionCheck.java:113) at org.owasp.dependencycheck.Engine.doUpdates(Engine.java:492) at org.owasp.dependencycheck.Engine.analyzeDependencies(Engine.java:346) at org.owasp.dependencycheck.maven.MavenEngine.analyzeDependencies(MavenEngine.java:95) at org.owasp.dependencycheck.maven.CheckMojo.runCheck(CheckMojo.java:97) at org.owasp.dependencycheck.maven.BaseDependencyCheckMojo.execute(BaseDependencyCheckMojo.java:423) at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59) at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183) at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320) at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156) at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537) at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196) at org.apache.maven.cli.MavenCli.main(MavenCli.java:141) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55) at java.lang.reflect.Method.invoke(Method.java:613)

    Users with the same issue

    ivanszkypeter
    2 times, last one,
    musketyr
    2 times, last one,
    tyson925
    27 times, last one,
    Hronom
    1 times, last one,
    Unknown visitor1 times, last one,
    109 more bugmates