java.lang.IllegalArgumentException

tip

Index settings can't be on the nodes via elasticsearch.yml. You need to set them at your index, or using index templates to avoid inconsistencies.


rafael

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • java.lang.IllegalArgumentException: unknown setting [cluster.routing.allocation.same_shard.host] did you mean any of [cluster.routing.allocation.balance.shard, cluster.routing.allocation.balance.threshold, cluster.routing.allocation.disk.watermark.high, cluster.routing.allocation.disk.watermark.low, cluster.routing.allocation.total_shards_per_node]? at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:270) at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:238) at org.elasticsearch.common.settings.SettingsModule.<init>(SettingsModule.java:138) at org.elasticsearch.node.Node.<init>(Node.java:236) at org.elasticsearch.node.Node.<init>(Node.java:173) at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:175) at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:175) at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:250) at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:96) at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:91) at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:91) at org.elasticsearch.cli.Command.main(Command.java:53) at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:70) at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:63)

Users with the same issue

rafael
1 times, last one,