org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/Ben12345rocks/VotingPlugin/Main : Unsupported major.minor version 52.0

GitHub | JumanjiCraft | 6 months ago
tip
Your exception is missing from the Samebug knowledge base.
Here are the best solutions we found on the Internet.
Click on the to mark the helpful solution and get rewards for you help.
  1. 0

    Major/Minor Error

    GitHub | 6 months ago | JumanjiCraft
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/Ben12345rocks/VotingPlugin/Main : Unsupported major.minor version 52.0
  2. 0

    GitHub comment 3#225650832

    GitHub | 8 months ago | NewgroundGaming
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/github/joelgodofwar/sps/PluginBase : Unsupported major.minor version 52.0
  3. 0

    GitHub comment 3#225933777

    GitHub | 8 months ago | NewgroundGaming
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/github/joelgodofwar/sps/PluginBase : Unsupported major.minor version 52.0
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    GitHub comment 174#228432450

    GitHub | 8 months ago | Arvin11kabir
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: nl/evolutioncoding/areashop/AreaShop : Unsupported major.minor version 51.0
  6. 0

    GitHub comment 174#228439604

    GitHub | 8 months ago | Arvin11kabir
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: nl/evolutioncoding/areashop/AreaShop : Unsupported major.minor version 51.0

  1. rafael 2 times, last 2 weeks ago
  2. andyglick 3 times, last 2 months ago
34 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. java.lang.UnsupportedClassVersionError

    com/Ben12345rocks/VotingPlugin/Main : Unsupported major.minor version 52.0

    at java.lang.ClassLoader.defineClass1()
  2. Java RT
    URLClassLoader.findClass
    1. java.lang.ClassLoader.defineClass1(Native Method)[?:1.7.0_101]
    2. java.lang.ClassLoader.defineClass(ClassLoader.java:803)[?:1.7.0_101]
    3. java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)[?:1.7.0_101]
    4. java.net.URLClassLoader.defineClass(URLClassLoader.java:449)[?:1.7.0_101]
    5. java.net.URLClassLoader.access$100(URLClassLoader.java:71)[?:1.7.0_101]
    6. java.net.URLClassLoader$1.run(URLClassLoader.java:361)[?:1.7.0_101]
    7. java.net.URLClassLoader$1.run(URLClassLoader.java:355)[?:1.7.0_101]
    8. java.security.AccessController.doPrivileged(Native Method)[?:1.7.0_101]
    9. java.net.URLClassLoader.findClass(URLClassLoader.java:354)[?:1.7.0_101]
    9 frames
  3. Bukkit
    PluginClassLoader.findClass
    1. org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101)[spigot.jar:git-Spigot-e0e1771-5e5cf84]
    2. org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86)[spigot.jar:git-Spigot-e0e1771-5e5cf84]
    2 frames
  4. Java RT
    Class.forName
    1. java.lang.ClassLoader.loadClass(ClassLoader.java:425)[?:1.7.0_101]
    2. java.lang.ClassLoader.loadClass(ClassLoader.java:358)[?:1.7.0_101]
    3. java.lang.Class.forName0(Native Method)[?:1.7.0_101]
    4. java.lang.Class.forName(Class.java:278)[?:1.7.0_101]
    4 frames
  5. Bukkit
    SimplePluginManager.loadPlugins
    1. org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64)[spigot.jar:git-Spigot-e0e1771-5e5cf84]
    2. org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131)[spigot.jar:git-Spigot-e0e1771-5e5cf84]
    3. org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329)[spigot.jar:git-Spigot-e0e1771-5e5cf84]
    4. org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251)[spigot.jar:git-Spigot-e0e1771-5e5cf84]
    4 frames
  6. org.bukkit.craftbukkit
    CraftServer.loadPlugins
    1. org.bukkit.craftbukkit.v1_10_R1.CraftServer.loadPlugins(CraftServer.java:297)[spigot.jar:git-Spigot-e0e1771-5e5cf84]
    1 frame
  7. net.minecraft.server
    MinecraftServer.run
    1. net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:203)[spigot.jar:git-Spigot-e0e1771-5e5cf84]
    2. net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:535)[spigot.jar:git-Spigot-e0e1771-5e5cf84]
    2 frames
  8. Java RT
    Thread.run
    1. java.lang.Thread.run(Thread.java:745)[?:1.7.0_101]
    1 frame