Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Oracle Community by karam84, 1 year ago
click on the v3 server node and select "runtime environment" link. If no JDK is there, you will need to install one and register it (using the link "installed JRE preferences" that can register both JREs and JDKs (Eclipse seems to mix JRE and JDKs...so
via thecodingforums.com by Unknown author, 2 years ago
Unable to compile class for JSP An error occurred at line: -1 in the jsp file: null Generated servlet error: [javac] Compiling 1 source file at org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:130) at org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:293) at org.apache.jasper.compiler.Compiler.generateClass(Compiler.java:353)
via Stack Overflow by kushagra
, 1 year ago
PWC6033: Error in Javac compilation for JSP PWC6197: An error occurred at line: 18 in the jsp file: /viewjsp.jsp PWC6199: Generated servlet error: cannot find symbol symbol: class HelloTag location: class org.apache.jsp.viewjsp_jsp PWC6197: An error
via Google Groups by Blanco, Jose, 7 months ago
Unable to compile class for JSPNote: sun.tools.javac.Main has been deprecated. An error occurred between lines: 342 and 349 in the jsp file: /browse/full.jsp Generated servlet error: /usr/local/jakarta-tomcat-4.0/work/Standalone
via Oracle Community by 843836, 1 year ago
Unable to compile class for JSPNote: sun.tools.javac.Main has been deprecated. error: An error has occurred in the compiler; please file a bug report (http://java.sun.com/cgi-bin/bugreport.cgi). 1 error, 1 warning
org.apache.jasper.JasperException: PWC6033: Unable to compile >> class for JSP[/b] >> >> I use JRE 6 > > You need to use JDK 6 (which includes tools.jar). > The JRE is not sufficient. Correct, You can setup the JDK used by GF v3 via Eclipse on the v3 server editor page...(double click on the v3 server node and select "runtime environment" link. If no JDK is there, you will need to install one and register it (using the link "installed JRE preferences" that can register both JREs and JDKs (Eclipse seems to mix JRE and JDKs...so it is confusing). Ludo > > > Jan > >> The LogFile: >> >> >> [b]PWC1406: Servlet.service() for servlet Faces Servlet threw >> exception java.lang.NullPointerException
at >> org.apache.jasper.compiler.Jsr199JavaCompiler.compile(Jsr199JavaCompiler.java:172) >>
at >> org.apache.jasper.compiler.Compiler.generateClass(Compiler.java:368) >>	at org.apache.jasper.compiler.Compiler.compile(Compiler.java:437)