com.sun.pkg.client.Constraint$DowngradeConflict

Package pkg-toolkit-incorporation contains constraint that requires downgrade of installed pkg pkg://dev.glassfish.org/pkg-java@1.122,0-38.2471:20090930T091727Z: Pkg pkg-java: Optional min_version: 1.122-37 max_version: 1.122-37 defined by: pkg:/pkg-toolkit-incorporation >>

Samebug tips0

We couldn't find tips for this exception.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web1

  • via Unknown by 392 Guest,
  • Stack trace

    • com.sun.pkg.client.Constraint$DowngradeConflict: Package pkg-toolkit-incorporation contains constraint that requires downgrade of installed pkg pkg://dev.glassfish.org/pkg-java@1.122,0-38.2471:20090930T091727Z: Pkg pkg-java: Optional min_version: 1.122-37 max_version: 1.122-37 defined by: pkg:/pkg-toolkit-incorporation >> at com.sun.pkg.client.Constraint.checkForWork(Constraint.java:365) at com.sun.pkg.client.Image$ImagePlan.evaluateFmri(Image.java:465) at com.sun.pkg.client.Image$ImagePlan.evaluate(Image.java:530) at com.sun.pkg.client.Image.makeAndEvaluateImagePlan(Image.java:1548) at com.sun.pkg.client.Image.makeInstallPlan(Image.java:1526) at com.sun.pkg.client.Image.installPackages(Image.java:1592) at com.sun.pkg.bootstrap.Bootstrap._main(Bootstrap.java:219) at com.sun.pkg.bootstrap.Bootstrap._main(Bootstrap.java:154) at com.sun.pkg.bootstrap.Bootstrap.main(Bootstrap.java:104)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    We couldn't find other users who have seen this exception.