io.ably.lib.types.AblyException

java.lang.Exception: HTTP Version Not Supported

Samebug tips0

We couldn't find tips for this exception.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web2

  • via GitHub by mattheworiordan
    ,
  • Stack trace

    • io.ably.lib.types.AblyException: java.lang.Exception: HTTP Version Not Supported at io.ably.lib.http.Http.httpExecute(Http.java:383) at io.ably.lib.http.Http.getUri(Http.java:194) at io.ably.lib.rest.Auth.requestToken(Auth.java:381) at io.ably.lib.http.TokenAuth.authorise(TokenAuth.java:54) at io.ably.lib.rest.Auth.authorise(Auth.java:325) at io.ably.lib.rest.Auth.getAuthParams(Auth.java:539) at io.ably.lib.transport.WebSocketTransport.connect(WebSocketTransport.java:59) at io.ably.lib.transport.ConnectionManager.connectImpl(ConnectionManager.java:614) at io.ably.lib.transport.ConnectionManager.handleStateRequest(ConnectionManager.java:421) at io.ably.lib.transport.ConnectionManager.run(ConnectionManager.java:529) at java.lang.Thread.run(Thread.java:818) Caused by: java.lang.Exception: HTTP Version Not Supported ... 11 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    We couldn't find other users who have seen this exception.