io.ably.lib.types.AblyException: java.lang.Exception: HTTP Version Not Supported

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via GitHub by mattheworiordan
, 1 year ago
java.lang.Exception: HTTP Version Not Supported
via GitHub by mattheworiordan
, 1 year ago
java.lang.Exception: HTTP Version Not Supported
via GitHub by SimonWoolf
, 1 year ago
javax.net.ssl.SSLHandshakeException: java.security.cert.CertPathValidatorException: Trust anchor for certification path not found.
java.lang.Exception: HTTP Version Not Supported
at io.ably.lib.http.Http.httpExecute(Http.java:383)
at io.ably.lib.http.Http.getUri(Http.java:194)
at io.ably.lib.rest.Auth.requestToken(Auth.java:381)
at io.ably.lib.http.TokenAuth.authorise(TokenAuth.java:54)
at io.ably.lib.rest.Auth.authorise(Auth.java:325)
at io.ably.lib.rest.Auth.getAuthParams(Auth.java:539)
at io.ably.lib.transport.WebSocketTransport.connect(WebSocketTransport.java:59)
at io.ably.lib.transport.ConnectionManager.connectImpl(ConnectionManager.java:614)
at io.ably.lib.transport.ConnectionManager.handleStateRequest(ConnectionManager.java:421)
at io.ably.lib.transport.ConnectionManager.run(ConnectionManager.java:529)
at java.lang.Thread.run(Thread.java:818)

Users with the same issue

You are the first who have seen this exception.

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.