Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Apache's JIRA Issue Tracker by Roald Hopman, 1 year ago
via lucene-general by A. Lotfi, 1 year ago
Could not load config for solrconfig.xml
via lucene-general by A. Lotfi, 1 year ago
Could not load config for solrconfig.xml
via Stack Overflow by Puneet Pandey
, 2 years ago
Could not load config for solrconfig.xml
org.apache.solr.common.SolrException: Could not load config for solrconfig.xml at org.apache.solr.core.CoreContainer.createFromLocal(CoreContainer.java:991) at org.apache.solr.core.CoreContainer.create(CoreContainer.java:1051) at org.apache.solr.core.CoreContainer$3.call(CoreContainer.java:634) at org.apache.solr.core.CoreContainer$3.call(CoreContainer.java:629) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) at java.util.concurrent.FutureTask.run(FutureTask.java:166) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) at java.util.concurrent.FutureTask.run(FutureTask.java:166) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at java.lang.Thread.run(Thread.java:679)Caused by: org.apache.solr.common.SolrException: Invalid luceneMatchVersion 'LUCENE_43', valid values are: [LUCENE_30, LUCENE_31, LUCENE_32, LUCENE_33, LUCENE_34, LUCENE_35, LUCENE_36, LUCENE_40, LUCENE_41, LUCENE_42, LUCENE_CURRENT] or a string in format 'V.V' at org.apache.solr.core.Config.parseLuceneVersionString(Config.java:313) at org.apache.solr.core.Config.getLuceneVersion(Config.java:298) at org.apache.solr.core.SolrConfig.<init>(SolrConfig.java:119) at org.apache.solr.core.CoreContainer.createFromLocal(CoreContainer.java:989) ... 11 moreCaused by: java.lang.IllegalArgumentException: No enum const class org.apache.lucene.util.Version.LUCENE_43 at java.lang.Enum.valueOf(Enum.java:214) at org.apache.lucene.util.Version.valueOf(Version.java:34) at org.apache.lucene.util.Version.parseLeniently(Version.java:133) at org.apache.solr.core.Config.parseLuceneVersionString(Config.java:311) ... 14 more