com.sun.xml.ws.util.ServiceConfigurationError

com.sun.xml.ws.api.pipe.TransportPipeFactory: Provider com.sun.enterprise.jbi.serviceengine.bridge.transport.JBITransportPipeFactory is specified in bundle://254.0:0/META-INF/services/com.sun.xml.ws.api.pipe.TransportPipeFactory but not found

Solutions on the web33

  • via Oracle Community by javamonkey79, 11 months ago
    com.sun.xml.ws.api.pipe.TransportPipeFactory: Provider com.sun.enterprise.jbi.serviceengine.bridge.transport.JBITransportPipeFactory is specified in bundle://254.0:0/META-INF/services/com.sun.xml.ws.api.pipe.TransportPipeFactory but not found
  • via Stack Overflow by javamonkey79
    , 1 year ago
    com.sun.xml.ws.api.pipe.TransportPipeFactory: Provider com.sun.enterprise.jbi.serviceengine.bridge.transport.JBITransportPipeFactory is specified in bundle://254.0:0/META-INF/services/com.sun.xml.ws.api.pipe.TransportPipeFactory but not found
  • via ws-juddi-user by Kurt T Stam, 9 months ago
    com.sun.xml.ws.api.pipe.TransportPipeFactory: Provider com.sun.enterprise.jbi.serviceengine.bridge.transport.JBITransportPipeFactory is specified in bundle://249.0:0/META-INF/services/com.sun.xml.ws.api.pipe.TransportPipeFactory but not found
  • Stack trace

    • com.sun.xml.ws.util.ServiceConfigurationError: com.sun.xml.ws.api.pipe.TransportPipeFactory: Provider com.sun.enterprise.jbi.serviceengine.bridge.transport.JBITransportPipeFactory is specified in bundle://254.0:0/META-INF/services/com.sun.xml.ws.api.pipe.TransportPipeFactory but not found at com.sun.xml.ws.util.ServiceFinder.fail(ServiceFinder.java:241) at com.sun.xml.ws.util.ServiceFinder.access$100(ServiceFinder.java:141) at com.sun.xml.ws.util.ServiceFinder$LazyIterator.next(ServiceFinder.java:376) at com.sun.xml.ws.api.pipe.TransportTubeFactory.create(TransportTubeFactory.java:129) at com.sun.xml.ws.transport.DeferredTransportPipe.<init>(DeferredTransportPipe.java:82) at com.sun.xml.ws.api.pipe.ClientTubeAssemblerContext.createTransportTube(ClientTubeAssemblerContext.java:311) at com.sun.xml.ws.assembler.jaxws.TransportTubeFactory.createTube(TransportTubeFactory.java:62) at com.sun.xml.ws.assembler.TubeCreator.createTube(TubeCreator.java:77) at com.sun.xml.ws.assembler.TubelineAssemblerFactoryImpl$MetroTubelineAssembler.createClient(TubelineAssemblerFactoryImpl.java:121) at com.sun.xml.ws.client.Stub.createPipeline(Stub.java:224) at com.sun.xml.ws.client.Stub.<init>(Stub.java:201) at com.sun.xml.ws.client.Stub.<init>(Stub.java:174) at com.sun.xml.ws.client.sei.SEIStub.<init>(SEIStub.java:81) at com.sun.xml.ws.client.WSServiceDelegate.createEndpointIFBaseProxy(WSServiceDelegate.java:602) at com.sun.xml.ws.client.WSServiceDelegate.getPort(WSServiceDelegate.java:344) at com.sun.xml.ws.client.WSServiceDelegate.getPort(WSServiceDelegate.java:326) at com.sun.xml.ws.client.WSServiceDelegate.getPort(WSServiceDelegate.java:308) at javax.xml.ws.Service.getPort(Service.java:99) at com.mycompany.myapp.webserviceclient.MyWebserviceService.getMyWebservicePort(InterfaceMetadataWebserviceService.java:58)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago