java.lang.ClassNotFoundException

org.apache.jasper.runtime.JspWriterImpl$1 from [Module "org.jboss.as.web:main" from local module loader @e61fd1 (roots: /Users/cfang/as/modules)]

Samebug tips1

Check if the version of resteasy is using is the same JBoss is using. To find it out, search for resteasy-jaxrs* in JBoss/Wildfly directory and at your pom.xml.


rafaelrafael

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web638

  • via Unknown by Cheng Fang,
  • via Unknown by Cheng Fang,
  • Stack trace

    • java.lang.ClassNotFoundException: org.apache.jasper.runtime.JspWriterImpl$1 from [Module "org.jboss.as.web:main" from local module loader @e61fd1 (roots: /Users/cfang/as/modules)] at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)[jboss-modules.jar:1.1.3.GA] at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)[jboss-modules.jar:1.1.3.GA] at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)[jboss-modules.jar:1.1.3.GA] at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)[jboss-modules.jar:1.1.3.GA] at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)[jboss-modules.jar:1.1.3.GA] at org.apache.jasper.security.SecurityClassLoad.securityClassLoad(SecurityClassLoad.java:107)[jbossweb-7.2.0.Alpha2.jar:7.2.0.Alpha2] at org.apache.jasper.compiler.JspRuntimeContext.<clinit>(JspRuntimeContext.java:72)[jbossweb-7.2.0.Alpha2.jar:7.2.0.Alpha2] at java.lang.Class.forName0(Native Method)[classes.jar:1.6.0_37] at java.lang.Class.forName(Class.java:247)[classes.jar:1.6.0_37] at org.apache.catalina.core.JasperListener.lifecycleEvent(JasperListener.java:52)[jbossweb-7.2.0.Alpha2.jar:7.2.0.Alpha2] at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:115)[jbossweb-7.2.0.Alpha2.jar:7.2.0.Alpha2] at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:406)[jbossweb-7.2.0.Alpha2.jar:7.2.0.Alpha2] at org.apache.catalina.core.StandardServer.init(StandardServer.java:393)[jbossweb-7.2.0.Alpha2.jar:7.2.0.Alpha2] at org.jboss.as.web.WebServerService.start(WebServerService.java:101)[jboss-as-web-7.2.0.Alpha1-SNAPSHOT.jar:7.2.0.Alpha1-SNAPSHOT] at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)[jboss-msc-1.0.2.GA.jar:1.0.2.GA] at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)[jboss-msc-1.0.2.GA.jar:1.0.2.GA] at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)[classes.jar:1.6.0_37] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)[classes.jar:1.6.0_37] at java.lang.Thread.run(Thread.java:680)[classes.jar:1.6.0_37]

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    81 more bugmates