java.lang.NoClassDefFoundError: org/osgi/framework/ServiceException

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Oracle Community by chris.joelly, 1 year ago
org/osgi/framework/ServiceException
via GitHub by bosschaert
, 2 years ago
via GitHub by esp1
, 2 years ago
org/osgi/framework/ServiceListener
via Stack Overflow by user1150769
, 2 years ago
org/newdawn/slick/BasicGame
java.lang.NoClassDefFoundError: org/osgi/framework/ServiceException
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at java.lang.Class.getDeclaredConstructors0(Native Method)
at java.lang.Class.privateGetDeclaredConstructors(Class.java:2389)
at java.lang.Class.getConstructor0(Class.java:2699)
at org.jboss.weld.util.ServiceLoader.prepareInstance(ServiceLoader.java:271)
at org.jboss.weld.util.ServiceLoader.loadService(ServiceLoader.java:238)
at org.jboss.weld.util.ServiceLoader.loadServiceFile(ServiceLoader.java:194)
at org.jboss.weld.util.ServiceLoader.reload(ServiceLoader.java:157)
at org.jboss.weld.util.ServiceLoader.iterator(ServiceLoader.java:346)
at org.jboss.weld.bootstrap.ExtensionBeanDeployer.addExtensions(ExtensionBeanDeployer.java:93)
at org.glassfish.weld.WeldDeployer.event(WeldDeployer.java:168)
at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:461)
at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:355)
at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:370)
at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1064)
at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1200(CommandRunnerImpl.java:96)
at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1244)
at com.sun.enterprise.admin.cli.embeddable.DeployerImpl.deploy(DeployerImpl.java:129)
at erp.test.TransactionTest.setUp(TransactionTest.java:111)

Users with the same issue

Once, 5 months ago
Once, 7 months ago
12 times, 7 months ago
Once, 1 year ago
14 times, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.