com.sun.enterprise.module.ResolveError

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Glassfish start issue with the most recent update
    via by user12154507,
    • com.sun.enterprise.module.ResolveError: Failed to start Bundle Id [330] State [INSTALLED] [org.glassfish.admingui.glassfish-osgi-console-plugin(Glassfish OSGI Console Plugin):3.1.1] at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:177) at org.jvnet.hk2.osgiadapter.OSGiModuleImpl$2$1$1.loadClass(OSGiModuleImpl.java:344) at com.sun.hk2.component.LazyInhabitant.loadClass(LazyInhabitant.java:124) at com.sun.hk2.component.LazyInhabitant.fetch(LazyInhabitant.java:111) at com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:135) at com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:76) at com.sun.enterprise.v3.server.ClassLoaderHierarchyImpl.createApplicationParentCL(ClassLoaderHierarchyImpl.java:200) at org.glassfish.deployment.common.DeploymentContextImpl.createClassLoader(DeploymentContextImpl.java:213) at org.glassfish.deployment.common.DeploymentContextImpl.createDeploymentClassLoader(DeploymentContextImpl.java:198) at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:346) at com.sun.enterprise.v3.server.ApplicationLoaderService.processApplication(ApplicationLoaderService.java:375) at com.sun.enterprise.v3.admin.adapter.InstallerThread.load(InstallerThread.java:210) at com.sun.enterprise.v3.admin.adapter.InstallerThread.run(InstallerThread.java:108) Caused by: org.osgi.framework.BundleException: Cannot start bundle org.glassfish.admingui.glassfish-osgi-console-plugin [330] because its start level is 2, which is greater than the framework's start level of 1. at org.apache.felix.framework.Felix.startBundle(Felix.java:1698) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:922) at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:169) ... 12 more

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    davidvanlaatumdavidvanlaatum
    28 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    10 more bugmates