com.facebook.react.modules.core.JavascriptException: C++ Exception in 'nativeRequireModuleConfig': java.lang.IncompatibleClassChangeError: The method 'java.io.File android.support.v4.content.ContextCompat.getNoBackupFilesDir(android.content.Context)' was expected to be of type virtual but instead was found to be of type direct (declaration of 'com.google.android.gms.iid.zzd' appears in /data/app/redacted/base.apk), stack: get@57:538 <unknown>@470:52 o@2:517 e@2:326 i@2:188 <unknown>@469:209 o@2:517 e@2:326 i@2:188 <unknown>@427:517 o@2:517 e@2:326 i@2:188 <unknown>@374:223 o@2:517 e@2:326 i@2:188 <unknown>@12:88 o@2:517 e@2:256 i@2:188 global code@639:9

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via GitHub by whs
, 1 year ago
found to be of type direct (declaration of 'com.google.android.gms.iid.zzd' appears in /data/app/redacted/base.apk), stack: get@57:538 <unknown>@470:52 o@2:517 e@2:326 i@2:188 <unknown>@469:209 o@2:517 e@2:326 i@2:188 <unknown>@427:517 o@2:517 e@2:326 i@2:188 <unknown>@374:223 o@2:517 e@2:326 i@2:188 <unknown>@12:88 o@2:517 e@2:256 i@2:188 global code@639:9
via GitHub by skating507
, 1 year ago
Requiring unknown module "../../../update.json"., stack: n@2:700 o@2:404 e@2:326 i@2:188 <unknown>@375:246 o@2:517 e@2:326 i@2:188 <unknown>@12:88 o@2:517 e@2:256 i@2:188 global code@556:9
via GitHub by skating507
, 1 year ago
Requiring unknown module "../../../update.json"., stack: n@2:700 o@2:404 e@2:326 i@2:188 <unknown>@375:246 o@2:517 e@2:326 i@2:188 <unknown>@12:88 o@2:517 e@2:256 i@2:188 global code@556:9
via GitHub by karkb
, 1 year ago
<unknown>@12:32 o@2:517 e@2:256 i@2:188 global code@819:9
via GitHub by chuyeoh
, 1 year ago
Requiring unknown module "react-native-spinkit", stack: t@2:387 i@2:177 <unknown>@720:131 t@2:511 i@2:177 <unknown>@710:297 t@2:511 i@2:177 <unknown>@645:278 t@2:511 i@2:177 <unknown>@640:387 t@2:511 i@2:177 <unknown>@638:180 t@2:511 i@2:177
via GitHub by texas697
, 1 year ago
Requiring unknown module "buffer", stack: 05-26 16:28:53.873 16192 16224 E AndroidRuntime: t@2:387 05-26 16:28:53.873 16192 16224 E AndroidRuntime: i@2:177 05-26 16:28:53.873 16192 16224 E AndroidRuntime: <unknown>@381:2868 05-26 16:28:53.873
com.facebook.react.modules.core.JavascriptException: C++ Exception in 'nativeRequireModuleConfig': java.lang.IncompatibleClassChangeError: The method 'java.io.File android.support.v4.content.ContextCompat.getNoBackupFilesDir(android.content.Context)' was expected to be of type virtual but instead was found to be of type direct (declaration of 'com.google.android.gms.iid.zzd' appears in /data/app/redacted/base.apk), stack: get@57:538 <unknown>@470:52 o@2:517 e@2:326 i@2:188 <unknown>@469:209 o@2:517 e@2:326 i@2:188 <unknown>@427:517 o@2:517 e@2:326 i@2:188 <unknown>@374:223 o@2:517 e@2:326 i@2:188 <unknown>@12:88 o@2:517 e@2:256 i@2:188 global code@639:9
at com.facebook.react.modules.core.ExceptionsManagerModule.showOrThrowError(ExceptionsManagerModule.java:94)
at com.facebook.react.modules.core.ExceptionsManagerModule.reportFatalException(ExceptionsManagerModule.java:78)
at com.facebook.react.bridge.BaseJavaModule$JavaMethod.invoke(BaseJavaModule.java:319)
at com.facebook.react.cxxbridge.JavaModuleWrapper.invoke(JavaModuleWrapper.java:139)
at com.facebook.react.bridge.queue.NativeRunnable.run(NativeRunnable.java)
at android.os.Handler.handleCallback(Handler.java:739)
at com.facebook.react.bridge.queue.MessageQueueThreadHandler.dispatchMessage(MessageQueueThreadHandler.java:31)
at android.os.Looper.loop(Looper.java:148)
at com.facebook.react.bridge.queue.MessageQueueThreadImpl$3.run(MessageQueueThreadImpl.java:196)
at java.lang.Thread.run(Thread.java:818)

Users with the same issue

You are the first who have seen this exception.

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.