org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS): DEPLOYMENTS MISSING DEPENDENCIES:   Deployment "AdminConsoleActivator" is missing the following dependencies:     Dependency "WebServer" (should be in state "Installed", but is actually in state "Configured")   Deployment "HAModClusterService" is missing the following dependencies:     Dependency "ModClusterConfig" (should be in state "Installed", but is actually in state "** NOT FOUND Depends on 'ModClusterConfig' **")   Deployment "JBossWSConsoleActivator" is missing the following dependencies:     Dependency "WebServer" (should be in state "Installed", but is actually in state "Configured")   Deployment "JmxConsoleActivator" is missing the following dependencies:     Dependency "WebServer" (should be in state "Installed", but is actually in state "Configured")   Deployment "ModClusterListener" is missing the following dependencies:     Dependency "HAModClusterService" (should be in state "Installed", but is actually in state "Described")   Deployment "WebServer" is missing the following dependencies:     Dependency "HAModClusterService" (should be in state "Create", but is actually in state "Described")   Deployment "jboss.web.deployment:war=/ROOT" is missing the following dependencies:     Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "Configured")   Deployment "jboss.web.deployment:war=/invoker" is missing the following dependencies:     Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "Configured")   Deployment "jboss.web.deployment:war=/juddi" is missing the following dependencies:     Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "Configured") DEPLOYMENTS IN ERROR:   Deployment "ModClusterConfig" is in error due to the following reason(s): ** NOT FOUND Depends on 'ModClusterConfig' **   Deployment "jboss.web:service=WebServer" is in error due to the following reason(s): Configured

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via jboss.org by Unknown author, 1 year ago
Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS): DEPLOYMENTS MISSING DEPENDENCIES:   Deployment "AdminConsoleActivator" is missing the following dependencies:     Dependency "WebServer" (should be in state "Installed", but is
via Coderanch by Deva Devan, 11 months ago
Summary of incomplete deploy ments (SEE PREVIOUS ERRORS FOR DETAILS): DEPLOYMENTS MISSING DEPENDENCIES: Deployment "jboss.jca:name=HibernateFactory,service=HibernateFactory" is missing the following dependencies: Dependency "jboss.jca:service
via Stack Overflow by povder
, 2 years ago
following dependencies: Dependency "jboss.naming:application=TestEar-0.0.1-SNAPSHOT,component=TestEjb,module=TestEjb-0.0.1-SNAPSHOT" (should be in state "Installed", but is actually in state "** NOT FOUND Depends on 'jboss.naming:application
via solutionscore.com by Unknown author, 2 years ago
following dependencies: Dependency "jboss.naming:application=TestEar-0.0.1-SNAPSHOT,component=TestEjb,module=TestEjb-0.0.1-SNAPSHOT" (should be in state "Installed", but is actually in state "** NOT FOUND Depends on 'jboss.naming:application
via Stack Overflow by user3102113
, 2 years ago
Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS): DEPLOYMENTS MISSING DEPENDENCIES: Deployment "jboss-switchboard:appName=mreport-gwt-gui-jee-7.1.0.0,module=mreport-gwt-gui-jee-7.1.0.0" is missing the following dependencies
via jboss.org by Unknown author, 1 year ago
Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS): *** CONTEXTS IN ERROR: Name -> Error vfszip:/C:/JBoss/5.0.0.GA/server/default/deploy/myApp.war -> file:/C:/JBoss/5.0.0.GA/server/default/tmp/deploy/myApp16062-exp.war/
org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS): DEPLOYMENTS MISSING DEPENDENCIES:   Deployment "AdminConsoleActivator" is missing the following dependencies:     Dependency "WebServer" (should be in state "Installed", but is actually in state "Configured")   Deployment "HAModClusterService" is missing the following dependencies:     Dependency "ModClusterConfig" (should be in state "Installed", but is actually in state "** NOT FOUND Depends on 'ModClusterConfig' **")   Deployment "JBossWSConsoleActivator" is missing the following dependencies:     Dependency "WebServer" (should be in state "Installed", but is actually in state "Configured")   Deployment "JmxConsoleActivator" is missing the following dependencies:     Dependency "WebServer" (should be in state "Installed", but is actually in state "Configured")   Deployment "ModClusterListener" is missing the following dependencies:     Dependency "HAModClusterService" (should be in state "Installed", but is actually in state "Described")   Deployment "WebServer" is missing the following dependencies:     Dependency "HAModClusterService" (should be in state "Create", but is actually in state "Described")   Deployment "jboss.web.deployment:war=/ROOT" is missing the following dependencies:     Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "Configured")   Deployment "jboss.web.deployment:war=/invoker" is missing the following dependencies:     Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "Configured")   Deployment "jboss.web.deployment:war=/juddi" is missing the following dependencies:     Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state "Configured") DEPLOYMENTS IN ERROR:   Deployment "ModClusterConfig" is in error due to the following reason(s): ** NOT FOUND Depends on 'ModClusterConfig' **   Deployment "jboss.web:service=WebServer" is in error due to the following reason(s): Configured
at org.jboss.deployers.plugins.deployers.DeployersImpl.checkComplete(DeployersImpl.java:1228)
at org.jboss.profileservice.deployment.ProfileDeployerPluginRegistry.checkAllComplete(ProfileDeployerPluginRegistry.java:107)
at org.jboss.system.server.profileservice.bootstrap.BasicProfileServiceBootstrap.start(BasicProfileServiceBootstrap.java:135)
at org.jboss.bootstrap.impl.base.server.AbstractServer.startBootstraps(AbstractServer.java:827)
at org.jboss.bootstrap.impl.base.server.AbstractServer$StartServerTask.run(AbstractServer.java:417)
at java.lang.Thread.run(Thread.java:662)

Users with the same issue

You are the first who have seen this exception. Write a tip to help other users and build your expert profile.

Know the solutions? Share your knowledge to help other developers to debug faster.