org.osgi.framework.BundleException: Could not resolve module: com.google.cloud.tools.eclipse.appengine.localserver [1044] Unresolved requirement: Require-Bundle: com.google.cloud.tools.eclipse.appengine.ui; bundle-version="0.1.0"

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via GitHub by elharo
, 1 year ago
Could not resolve module: com.google.cloud.tools.eclipse.appengine.localserver [1044] Unresolved requirement: Require-Bundle: com.google.cloud.tools.eclipse.appengine.ui; bundle-version="0.1.0"
via GitHub by muhuk
, 2 years ago
Could not resolve module: frege.ide [1815] Unresolved requirement: Require-Bundle: impulse; bundle-version="0.1.0" -> Bundle-SymbolicName: impulse; bundle-version="0.1.0.201510181252"; singleton:="true" impulse [1816] Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"
via Stack Overflow by Nayantara Jeyaraj
, 3 months ago
Could not resolve module: org.sonatype.m2e.mavenarchiver [1674] Unresolved requirement: Require-Bundle: org.eclipse.m2e.jdt; bundle-version="[1.0.0,2.0.0)" -> Bundle-SymbolicName: org.eclipse.m2e.jdt; bundle-version="1.6.2.20150902-0002
via talendforge.org by Unknown author, 1 year ago
Could not resolve module: org.talend.cwm.compare [214] Unresolved requirement: Require-Bundle: org.eclipse.emf.compare.rcp -> Bundle-SymbolicName: org.eclipse.emf.compare.rcp; bundle-version= ; singleton:= org.eclipse.emf.compare.rcp [192] Unresolved requirement: Require-Bundle: org.eclipse.emf.compare.edit; bundle-version=
via GitHub by KevinPhemius
, 1 year ago
Could not resolve module: eu.netide.configuration.launcher [750] Unresolved requirement: Require-Bundle: org.eclipse.debug.ui; bundle-version="3.10.1"
via GitHub by nobeh
, 1 year ago
Could not resolve module: org.abs-models.abs.plugin [531] Unresolved requirement: Require-Bundle: org.abs-models.sdedit; bundle-version="0.0.0"
org.osgi.framework.BundleException: Could not resolve module: com.google.cloud.tools.eclipse.appengine.localserver [1044] Unresolved requirement: Require-Bundle: com.google.cloud.tools.eclipse.appengine.ui; bundle-version="0.1.0"
at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
43 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.