java.lang.UnsatisfiedLinkError: /tmp/librocksdbjni8724249777028282150.so: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /tmp/librocksdbjni8724249777028282150.so)

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,
Expert tip

When installing an APK, it automatically extracts the libraries of the right arch type and has them available for System.loadLibrary. But, if you're trying to load a non-standard library, the installer won't know your app has 32bit native code.

Solutions on the web

via GitHub by adamretter
, 1 year ago
/tmp/librocksdbjni8724249777028282150.so: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /tmp/librocksdbjni8724249777028282150.so)
via Stack Overflow by Matthias
, 2 years ago
/usr/lib/file.so: /usr/lib/file.so: cannot open shared object file: No such file or directory (Possible cause: can't load ARM-bit .so on a IA 32-bit platform)
via boatingclouds.com by Unknown author, 2 years ago
/tmp/snappy-1.0.4.1-1d6b68c7-7b65-4c0b-8008-19f112c714ea-libsnappyjava.so: /tmp/snappy-1.0.4.1-1d6b68c7-7b65-4c0b-8008-19f112c714ea-libsnappyjava.so: failed to map segment from shared object: Operation not permitted
via GitHub by Eipifi
, 2 years ago
/tmp/z3/build/libz3java.so: libz3.so: cannot open shared object file: No such file or directory
via GitHub by gtch
, 2 years ago
/Users/admin/Documents/HearthStats.app/Contents/Resources/tmp/liblept169.dylib: dlopen(/Users/admin/Documents/HearthStats.app/Contents/Resources/tmp/liblept169.dylib, 1): Library not loaded: /usr/local/lib/libpng15.15.dylib Referenced from: /Users/admin/Documents/HearthStats.app/Contents/Resources/tmp/liblept169.dylib Reason: image not found
via GitHub by blucas
, 2 years ago
/tmp/libnetty-tcnative8018331010701115954.so: /usr/lib/x86_64-linux-gnu/libssl.so.10: version `libssl.so.10' not found (required by /tmp/libnetty-tcnative8018331010701115954.so)
java.lang.UnsatisfiedLinkError: /tmp/librocksdbjni8724249777028282150.so: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /tmp/librocksdbjni8724249777028282150.so)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1968)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1893)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1854)
at java.lang.Runtime.load0(Runtime.java:795)
at java.lang.System.load(System.java:1062)
at org.rocksdb.NativeLibraryLoader.loadLibraryFromJar(NativeLibraryLoader.java:78)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
84 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.