java.lang.NoClassDefFoundError

org/eclipse/ui/PlatformUI at org.eclipse.jst.ws.internal.consumption.command.common.StartServerCommand.publish(StartServerCommand.java:185) at org.eclipse.jst.ws.internal.consumption.command.common.StartServerCommand.execute(StartServerCommand.java:101) at org.eclipse.jst.ws.internal.creation.ui.extension.PreServiceRunCommand.execute(PreServiceRunCommand.java:30) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.runCommand(CommandFragmentEngine.java:335) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.visitTop(CommandFragmentEngine.java:301) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.moveForwardToNextStop(CommandFragmentEngine.java:217) at org.eclipse.wst.command.internal.env.ui.widgets.SimpleCommandEngineManager$4.run(SimpleCommandEngineManager.java:208) at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:346)

Solutions on the web20566

  • via Eclipse Bugzilla by bcjoshi, 10 months ago
    (CommandFragmentEngine.java:217) at org.eclipse.wst.command.internal.env.ui.widgets.SimpleCommandEngineManager$4.run(SimpleCommandEngineManager.java:208) at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:346)
  • via grokbase.com by Unknown author, 1 year ago
    org/apache/xml/serializer/TreeWalker at org.apache.xalan.processor.TransformerFactoryImpl.newTransformer(TransformerFactoryImpl.java:821) at org.apache.servicemix.jbi.jaxp.SourceTransformer.createTransfomer(SourceTransformer.java:476) at
  • via Eclipse Bugzilla by billy.biggs, 1 year ago
    org/eclipse/ui/internal/misc/StatusUtil at org.eclipse.ui.internal.decorators.LightweightDecoratorManager$LightweightRunnable.handleException(LightweightDecoratorManager.java:55) at org.eclipse.core.internal.runtime.InternalPlatform.handleException(InternalPlatform.java:350) at org.eclipse.core.internal.runtime.InternalPlatform.run(InternalPlatform.java:618)
  • Stack trace

    • java.lang.NoClassDefFoundError: org/eclipse/ui/PlatformUI at org.eclipse.jst.ws.internal.consumption.command.common.StartServerCommand.publish(StartServerCommand.java:185) at org.eclipse.jst.ws.internal.consumption.command.common.StartServerCommand.execute(StartServerCommand.java:101) at org.eclipse.jst.ws.internal.creation.ui.extension.PreServiceRunCommand.execute(PreServiceRunCommand.java:30) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.runCommand(CommandFragmentEngine.java:335) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.visitTop(CommandFragmentEngine.java:301) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.moveForwardToNextStop(CommandFragmentEngine.java:217) at org.eclipse.wst.command.internal.env.ui.widgets.SimpleCommandEngineManager$4.run(SimpleCommandEngineManager.java:208) at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:346) at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:291) at org.eclipse.jface.wizard.WizardDialog.run(WizardDialog.java:830)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You are the first who have seen this exception. Write a tip to help other users and build your expert profile.