java.lang.NoClassDefFoundError: org/eclipse/ui/PlatformUI at org.eclipse.jst.ws.internal.consumption.command.common.StartServerCommand.publish(StartServerCommand.java:185) at org.eclipse.jst.ws.internal.consumption.command.common.StartServerCommand.execute(StartServerCommand.java:101) at org.eclipse.jst.ws.internal.creation.ui.extension.PreServiceRunCommand.execute(PreServiceRunCommand.java:30) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.runCommand(CommandFragmentEngine.java:335) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.visitTop(CommandFragmentEngine.java:301) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.moveForwardToNextStop(CommandFragmentEngine.java:217) at org.eclipse.wst.command.internal.env.ui.widgets.SimpleCommandEngineManager$4.run(SimpleCommandEngineManager.java:208) at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:346)

Eclipse Bugzilla | bcjoshi | 1 decade ago
tip
Do you know that we can give you better hits? Get more relevant results from Samebug’s stack trace search.
  1. 0

    java.lang.NoClassDefFoundError: javax/activation/DataSource

    Eclipse Bugzilla | 1 decade ago | bcjoshi
    java.lang.NoClassDefFoundError: org/eclipse/ui/PlatformUI at org.eclipse.jst.ws.internal.consumption.command.common.StartServerCommand.publish(StartServerCommand.java:185) at org.eclipse.jst.ws.internal.consumption.command.common.StartServerCommand.execute(StartServerCommand.java:101) at org.eclipse.jst.ws.internal.creation.ui.extension.PreServiceRunCommand.execute(PreServiceRunCommand.java:30) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.runCommand(CommandFragmentEngine.java:335) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.visitTop(CommandFragmentEngine.java:301) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.moveForwardToNextStop(CommandFragmentEngine.java:217) at org.eclipse.wst.command.internal.env.ui.widgets.SimpleCommandEngineManager$4.run(SimpleCommandEngineManager.java:208) at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:346)

    Root Cause Analysis

    1. java.lang.NoClassDefFoundError

      org/eclipse/ui/PlatformUI at org.eclipse.jst.ws.internal.consumption.command.common.StartServerCommand.publish(StartServerCommand.java:185) at org.eclipse.jst.ws.internal.consumption.command.common.StartServerCommand.execute(StartServerCommand.java:101) at org.eclipse.jst.ws.internal.creation.ui.extension.PreServiceRunCommand.execute(PreServiceRunCommand.java:30) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.runCommand(CommandFragmentEngine.java:335) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.visitTop(CommandFragmentEngine.java:301) at org.eclipse.wst.command.internal.env.core.fragment.CommandFragmentEngine.moveForwardToNextStop(CommandFragmentEngine.java:217) at org.eclipse.wst.command.internal.env.ui.widgets.SimpleCommandEngineManager$4.run(SimpleCommandEngineManager.java:208) at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:346)

      at org.eclipse.jface.operation.ModalContext.run()
    2. JFace
      WizardDialog.run
      1. org.eclipse.jface.operation.ModalContext.run(ModalContext.java:291)
      2. org.eclipse.jface.wizard.WizardDialog.run(WizardDialog.java:830)
      2 frames