java.net.BindException

Problem binding to [0.0.0.0:50010] java.net.BindException: Address already in use; For more details see: http://wiki.apache.org/hadoop/BindException

Samebug tips3

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web4211

  • Problem binding to [0.0.0.0:50010] java.net.BindException: Address already in use; For more details see: http://wiki.apache.org/hadoop/BindException
  • Problem binding to [0.0.0.0:50010] java.net.BindException: Address already in use; For more details see: http://wiki.apache.org/hadoop/BindException
  • Problem binding to [0.0.0.0:50010] java.net.BindException: Address already in use; For more details see: http://wiki.apache.org/hadoop/BindException
  • Stack trace

    • java.net.BindException: Problem binding to [0.0.0.0:50010] java.net.BindException: Address already in use; For more details see: http://wiki.apache.org/hadoop/BindException at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) at java.lang.reflect.Constructor.newInstance(Constructor.java:423) at org.apache.hadoop.net.NetUtils.wrapWithMessage(NetUtils.java:791) at org.apache.hadoop.net.NetUtils.wrapException(NetUtils.java:720) at org.apache.hadoop.ipc.Server.bind(Server.java:424) at org.apache.hadoop.ipc.Server.bind(Server.java:396) at org.apache.hadoop.hdfs.net.TcpPeerServer.<init>(TcpPeerServer.java:111) at org.apache.hadoop.hdfs.server.datanode.DataNode.initDataXceiver(DataNode.java:871) at org.apache.hadoop.hdfs.server.datanode.DataNode.startDataNode(DataNode.java:1084) at org.apache.hadoop.hdfs.server.datanode.DataNode.<init>(DataNode.java:417) at org.apache.hadoop.hdfs.server.datanode.DataNode.makeInstance(DataNode.java:2328) at org.apache.hadoop.hdfs.server.datanode.DataNode.instantiateDataNode(DataNode.java:2215) at org.apache.hadoop.hdfs.server.datanode.DataNode.createDataNode(DataNode.java:2262) at org.apache.hadoop.hdfs.server.datanode.DataNode.secureMain(DataNode.java:2438) at org.apache.hadoop.hdfs.server.datanode.DataNode.main(DataNode.java:2462) Caused by: java.net.BindException: Address already in use at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Net.java:433) at sun.nio.ch.Net.bind(Net.java:425) at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74) at org.apache.hadoop.ipc.Server.bind(Server.java:407) ... 10 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    35 times, 2 hours ago
    9 times, 1 day ago
    Once, 3 days ago
    8 times, 1 week ago
    Once, 1 week ago
    143 more bugmates