java.net.ConnectException

If you like a tip written by other Samebug users, mark is as helpful! Marks help our algorithm provide you better solutions and also help other users.
tip

host port isnt set

tip

Check if your MongoDB is available.


rp
tip

To restart the Selenium Webdriver mock browser in a testcase, first use 'driver.close()' and then reinstantiate the driver.

tip

Firewall might be blocking your connection, or MySQL it's not running on your server machine.


rafael
tip

Check if you have started your server, or if your server is set to listen to the port you're trying to connect and is waiting to accept connections and check if the firewall isn't blocking your connection.


rafael
tip

Check if ip adress is correct, if the port is correct, and if the server is up and running and waiting for connections. Also, check if there's no firewall blocking you and if your internet connection is working.


rafael
tip

spring-data-redis requires redis 2.6+ to work properly.

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Hive Table Mapping with MongoDB
    via Stack Overflow by Karthigai muthu
    ,
  • GitHub comment 391#157183661
    via GitHub by paulochf
    ,
  • IO Error configuring JDBC for localhost database
    via by Jose Aróstegui,
  • Web Center Sites Login issue
    via by 2697344,
    • java.net.ConnectException: Connection refused at java.net.PlainSocketImpl.socketConnect(Native Method) at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339) at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200) at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182) at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) at java.net.Socket.connect(Socket.java:579) at org.apache.ignite.spi.discovery.tcp.TcpDiscoverySpi.openSocket(TcpDiscoverySpi.java:1266) at org.apache.ignite.spi.discovery.tcp.TcpDiscoverySpi.openSocket(TcpDiscoverySpi.java:1241) at org.apache.ignite.spi.discovery.tcp.ClientImpl.sendJoinRequest(ClientImpl.java:579) at org.apache.ignite.spi.discovery.tcp.ClientImpl.joinTopology(ClientImpl.java:505) at org.apache.ignite.spi.discovery.tcp.ClientImpl.access$900(ClientImpl.java:118) at org.apache.ignite.spi.discovery.tcp.ClientImpl$MessageWorker.tryJoin(ClientImpl.java:1508) at org.apache.ignite.spi.discovery.tcp.ClientImpl$MessageWorker.body(ClientImpl.java:1327) at org.apache.ignite.spi.IgniteSpiThread.run(IgniteSpiThread.java:62)

    Users with the same issue

    Luka
    1 times, last one,
    Handemelindo
    2 times, last one,
    mortalman7
    1 times, last one,
    jedcua
    1 times, last one,
    Unknown visitor1 times, last one,
    479 more bugmates