com.android.dex.DexException: Multiple dex files define Lcom/parse/AbstractQueryController$1; At first, I thought the problem could be solved by downloading the API16 on the SDK manager(before that I only had API23 installed) but it didn't work. I have a guess that my problem has something to do with these lines: compile 'com.android.support:design:23.+' and buildToolsVersion "23.0.3" because they refer to API23 design or something like that, anyone can help? EDIT: I get this following error now that I have specified the files I want gradle to compile: InflateException: Binary XML file line #22: Error inflating class Button

tip
Click on the to mark the solution that helps you, Samebug will learn from it.
As a community member, you’ll be rewarded for you help.
  1. 0

    Application doesn't run on older android versions

    Stack Overflow | 6 months ago | Bruno Brandão Borges
    com.android.dex.DexException: Multiple dex files define Lcom/parse/AbstractQueryController$1; At first, I thought the problem could be solved by downloading the API16 on the SDK manager(before that I only had API23 installed) but it didn't work. I have a guess that my problem has something to do with these lines: compile 'com.android.support:design:23.+' and buildToolsVersion "23.0.3" because they refer to API23 design or something like that, anyone can help? EDIT: I get this following error now that I have specified the files I want gradle to compile: InflateException: Binary XML file line #22: Error inflating class Button

    Root Cause Analysis

    1. com.android.dex.DexException

      Multiple dex files define Lcom/parse/AbstractQueryController$1; At first, I thought the problem could be solved by downloading the API16 on the SDK manager(before that I only had API23 installed) but it didn't work. I have a guess that my problem has something to do with these lines: compile 'com.android.support:design:23.+' and buildToolsVersion "23.0.3" because they refer to API23 design or something like that, anyone can help? EDIT: I get this following error now that I have specified the files I want gradle to compile: InflateException: Binary XML file line #22: Error inflating class Button

      at com.example.branco.sauce.ListViewAdapter.getView()
    2. com.example.branco
      ListViewAdapter.getView
      1. com.example.branco.sauce.ListViewAdapter.getView(ListViewAdapter.java:88)
      1 frame