java.lang.RuntimeException

No solution found because the problem is unsatisfiable.: [Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.ui 0.0.0.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.core.runtime 0.0.0.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.jdt.core 3.9.2.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.core.resources 3.8.101.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.jdt.ui 3.9.2.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.ui.console 3.5.200.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.ui.editors 3.8.100.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle com.test.dependency.bundles 1.0.0.; Unable to satisfy dependency from xxx 1.0.0.qualifier to package org.eclipse.jface.text 0.0.0.; Unable to satisfy dependency from test- automation-plugin 1.0.0.qualifier to package org.eclipse.jface.text.presentation 0.0.0.; Unable to satisfy dependency from txxx 1.0.0.qualifier to package org.eclipse.jface.text.rules 0.0.0.; Unable to satisfy dependency from xxx 1.0.0.qualifier to package org.eclipse.jface.text.source 0.0.0.; No solution found because the problem is unsatisfiable.] -> [Help 1]

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web49376

  • 1.0.0.qualifier to package org.eclipse.jface.text.presentation 0.0.0.; Unable to satisfy dependency from txxx 1.0.0.qualifier to package org.eclipse.jface.text.rules 0.0.0.; Unable to satisfy dependency from xxx 1.0.0.qualifier to package org.eclipse.jface.text.source 0.0.0.; No solution found because the problem is unsatisfiable.] -> [Help 1]
  • via Google Groups by Cosmas Chan, 6 months ago
    "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.application 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0
  • via GitHub by jantje
    , 6 months ago
    No solution found because the problem is unsatisfiable.: [Unable to satisfy dependency from it.baeyens.arduino.common 2.4.0.qualifier to bundle org.eclipse.ui 0.0.0.; Unable to satisfy dependency from it.baeyens.arduino.common 2.4.0.qualifier to
  • Stack trace

    • java.lang.RuntimeException: No solution found because the problem is unsatisfiable.: [Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.ui 0.0.0.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.core.runtime 0.0.0.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.jdt.core 3.9.2.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.core.resources 3.8.101.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.jdt.ui 3.9.2.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.ui.console 3.5.200.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle org.eclipse.ui.editors 3.8.100.; Unable to satisfy dependency from xxx 1.0.0.qualifier to bundle com.test.dependency.bundles 1.0.0.; Unable to satisfy dependency from xxx 1.0.0.qualifier to package org.eclipse.jface.text 0.0.0.; Unable to satisfy dependency from test- automation-plugin 1.0.0.qualifier to package org.eclipse.jface.text.presentation 0.0.0.; Unable to satisfy dependency from txxx 1.0.0.qualifier to package org.eclipse.jface.text.rules 0.0.0.; Unable to satisfy dependency from xxx 1.0.0.qualifier to package org.eclipse.jface.text.source 0.0.0.; No solution found because the problem is unsatisfiable.] -> [Help 1] at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:168) at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537) at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196) at org.apache.maven.cli.MavenCli.main(MavenCli.java:141) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290) at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230) at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409) at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You’re the first here who have seen this exception.