java.net.BindException

Address already in use

Samebug tips3

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.


rafaelrafael

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.


rafaelrafael

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web912

Stack trace

  • java.net.BindException: Address already in use at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Net.java:433) at sun.nio.ch.Net.bind(Net.java:425) at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:67) at org.apache.zookeeper.server.NIOServerCnxnFactory.configure(NIOServerCnxnFactory.java:95) at org.apache.zookeeper.server.quorum.QuorumPeerMain.runFromConfig(QuorumPeerMain.java:130) at org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPeerMain.java:111) at org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:78)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

slashslash
8 times, last one
zsambokizsamboki
6 times, last one
Unknown UserUnknown User
Once,
rocdayrocday
2 times, last one
Михайло ТітовМихайло Тітов
2 times, last one
141 more bugmates