Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Stack Overflow by Jose
, 1 year ago
Could not start bundle mvn:com.xxx/xxxapi in feature(s) xxx-0.0.0: Unresolved constraint in bundle com.xxx.xxx-api [406]: Unable to resolve 406.0: missing requirement [406.0] osgi.wiring.package; (osgi.wiring.package=org.jboss.resteasy.plugins.providers.multipart)
via grokbase.com by Unknown author, 2 years ago
Could not start bundle mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.saaj-impl/1.3.2_1 in feature(s) camel-cxf-2.6.0: Unresolved constraint in bundle org.apache.servicemix.bundles.saaj-impl [97]: Unable to resolve 97.0: missing requirement [97.0] package; (package=com.sun.org.apache.xerces.internal.dom)
via nabble.com by Unknown author, 2 years ago
Could not start bundle mvn:com.test.data/datasource-service/1.0.0-SNAPSHOT in feature(s) datasource-service-1.0.0-SNAPSHOT: Unresolved constraint in bundle com.test.data.datasource-service [217]: Unable to resolve 217.0: missing requirement [217.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.transaction)(version>=4.0.2.RELESE))
java.lang.Exception: Could not start bundle mvn:com.xxx/xxxapi in feature(s) xxx-0.0.0: Unresolved constraint in bundle com.xxx.xxx-api [406]: Unable to resolve 406.0: missing requirement [406.0] osgi.wiring.package; (osgi.wiring.package=org.jboss.resteasy.plugins.providers.multipart) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:482)[49:org.apache.karaf.features.core:2.3.1] at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:396)[49:org.apache.karaf.features.core:2.3.1] at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:392)[49:org.apache.karaf.features.core:2.3.1] at org.apache.karaf.features.command.InstallFeatureCommand.doExecute(InstallFeatureCommand.java:62)[34:org.apache.karaf.features.command:2.3.1] at org.apache.karaf.features.command.FeaturesCommandSupport.doExecute(FeaturesCommandSupport.java:41)[34:org.apache.karaf.features.command:2.3.1] at org.apache.karaf.shell.console.OsgiCommandSupport.execute(OsgiCommandSupport.java:38)[23:org.apache.karaf.shell.console:2.3.1] at org.apache.felix.gogo.commands.basic.AbstractCommand.execute(AbstractCommand.java:35)[23:org.apache.karaf.shell.console:2.3.1] at org.apache.felix.gogo.runtime.CommandProxy.execute(CommandProxy.java:78)[23:org.apache.karaf.shell.console:2.3.1] at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:474)[23:org.apache.karaf.shell.console:2.3.1] at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:400)[23:org.apache.karaf.shell.console:2.3.1] at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)[23:org.apache.karaf.shell.console:2.3.1] at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)[23:org.apache.karaf.shell.console:2.3.1] at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)[23:org.apache.karaf.shell.console:2.3.1] at org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:89)[23:org.apache.karaf.shell.console:2.3.1] at org.apache.karaf.shell.console.jline.Console.run(Console.java:174)[23:org.apache.karaf.shell.console:2.3.1] at java.lang.Thread.run(Thread.java:745)[:1.7.0_80]Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.xxx-api [406]: Unable to resolve 406.0: missing requirement [406.0] osgi.wiring.package; (osgi.wiring.package=org.jboss.resteasy.plugins.providers.multipart) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)[org.apache.felix.framework-4.0.3.jar:] at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)[org.apache.felix.framework-4.0.3.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)[org.apache.felix.framework-4.0.3.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)[org.apache.felix.framework-4.0.3.jar:] at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:479)[49:org.apache.karaf.features.core:2.3.1] ... 15 more