java.lang.NoClassDefFoundError: Could not initialize class org.eclipse.xtext.resource.XtextResourceSet$1

GitHub | surisetty | 6 months ago
tip
Click on the to mark the solution that helps you, Samebug will learn from it.
As a community member, you’ll be rewarded for you help.
  1. 0

    OpenHAB Rspberry Pi not starting

    GitHub | 6 months ago | surisetty
    java.lang.NoClassDefFoundError: Could not initialize class org.eclipse.xtext.resource.XtextResourceSet$1

    Root Cause Analysis

    1. java.lang.NoClassDefFoundError

      Could not initialize class org.eclipse.xtext.resource.XtextResourceSet$1

      at org.eclipse.xtext.resource.XtextResourceSet.getURIConverter()
    2. org.eclipse.xtext
      SynchronizedXtextResourceSet.getResource
      1. org.eclipse.xtext.resource.XtextResourceSet.getURIConverter(XtextResourceSet.java:170)[na:na]
      2. org.eclipse.xtext.resource.XtextResourceSet.getResource(XtextResourceSet.java:136)[na:na]
      3. org.eclipse.xtext.resource.SynchronizedXtextResourceSet.getResource(SynchronizedXtextResourceSet.java:23)[na:na]
      3 frames
    3. org.openhab.model
      FolderObserver.run
      1. org.openhab.model.core.internal.ModelRepositoryImpl.getResource(ModelRepositoryImpl.java:153)[na:na]
      2. org.openhab.model.core.internal.ModelRepositoryImpl.addOrRefreshModel(ModelRepositoryImpl.java:71)[na:na]
      3. org.openhab.model.core.internal.folder.FolderObserver.checkFolder(FolderObserver.java:142)[na:na]
      4. org.openhab.model.core.internal.folder.FolderObserver.run(FolderObserver.java:99)[na:na]
      4 frames