java.lang.IllegalArgumentException: invalid version "2.1.0.beta.119": invalid qualifier "beta.119"

GitHub | 33d | 9 months ago
tip
Your exception is missing from the Samebug knowledge base.
Here are the best solutions we found on the Internet.
Click on the to mark the helpful solution and get rewards for you help.
  1. 0

    Dependencies with illegal qualifiers aren't included

    GitHub | 9 months ago | 33d
    java.lang.IllegalArgumentException: invalid version "2.1.0.beta.119": invalid qualifier "beta.119"
  2. 0

    module version number

    terracotta.org | 2 years ago
    org.osgi.framework.BundleException: Invalid module specification: name=my-module, version=2.6.0RC1-SNAPSHOT, groupId=my.project
  3. 0

    Camel - Users - JAAS auth + Jetty - Exception

    nabble.com | 1 year ago
    java.lang.IllegalArgumentException: invalid format
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.IllegalArgumentException

      invalid version "2.1.0.beta.119": invalid qualifier "beta.119"

      at org.osgi.framework.Version.validate()
    2. OSGi
      Version.parseVersion
      1. org.osgi.framework.Version.validate(Version.java:205)
      2. org.osgi.framework.Version.<init>(Version.java:156)
      3. org.osgi.framework.Version.parseVersion(Version.java:233)
      3 frames
    3. Eclipse OSGi
      StateBuilder.createBundleDescription
      1. org.eclipse.osgi.internal.resolver.StateBuilder.createBundleDescription(StateBuilder.java:94)
      1 frame