javax.xml.rpc.soap.SOAPFaultException

oracle.fabric.common.FabricInvocationException: weblogic.sca.api.ScaException: java.lang.NoClassDefFoundError: org/docx4j/XmlUtils[[

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web11

  • oracle.fabric.common.FabricInvocationException: weblogic.sca.api.ScaException: java.lang.NoClassDefFoundError: org/docx4j/XmlUtils[[
  • via Oracle Community by 894134, 11 months ago
    oracle.fabric.common.FabricInvocationException: Unable to access the following endpoint(s): https://txganguat.txd ps.state.tx.us/TxGang
  • EXCEPTION: java.lang.NoClassDefFoundError [ServiceException]
  • Stack trace

    • javax.xml.rpc.soap.SOAPFaultException: oracle.fabric.common.FabricInvocationException: weblogic.sca.api.ScaException: java.lang.NoClassDefFoundError: org/docx4j/XmlUtils[[ at oracle.integration.platform.blocks.soap.WebServiceEntryBindingComponent.generateSoapFaultException(WebServiceEntryBindingComponent.java:1280) at oracle.integration.platform.blocks.soap.WebServiceEntryBindingComponent.processIncomingMessage(WebServiceEntryBindingComponent.java:1053) at oracle.integration.platform.blocks.soap.FabricProvider.processMessage(FabricProvider.java:113) at oracle.j2ee.ws.server.provider.ProviderProcessor.doEndpointProcessing(ProviderProcessor.java:1187) at oracle.j2ee.ws.server.WebServiceProcessor.invokeEndpointImplementation(WebServiceProcessor.java:1123) at oracle.j2ee.ws.server.provider.ProviderProcessor.doRequestProcessing(ProviderProcessor.java:581) at oracle.j2ee.ws.server.WebServiceProcessor.processRequest(WebServiceProcessor.java:235) at oracle.j2ee.ws.server.WebServiceProcessor.doService(WebServiceProcessor.java:196) at oracle.j2ee.ws.server.WebServiceServlet.doPost(WebServiceServlet.java:487)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You’re the first here who have seen this exception.