java.lang.NoClassDefFoundError

com/jme3/app/state/BaseAppState

Samebug tips8

You might've forgot to add a dependency or it's written wrong. Also, you might be using incompatible versions of Java and Hibernate. More on this here: https://goo.gl/SjSlRA

If you're using Hibernate, this indicates you're missing FasterXML Classmate dependency, which you can add to your dependencies. To add it, the groupId is com.fasterxml and artifactId is Classmate.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web8611

  • via jmonkeyengine.org by Unknown author, 10 months ago
    com/jme3/app/state/BaseAppState
  • via Stack Overflow by onesixtyfourth
    , 1 year ago
    com/jme3/app/SimpleApplication
  • via GitHub by i-make-robots
    , 1 year ago
    com/jme3/input/lwjgl/GlfwMouseInput
  • Stack trace

    • java.lang.NoClassDefFoundError: com/jme3/app/state/BaseAppState at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:800) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) at java.net.URLClassLoader.defineClass(URLClassLoader.java:449) at java.net.URLClassLoader.access$100(URLClassLoader.java:71) at java.net.URLClassLoader$1.run(URLClassLoader.java:361) at java.net.URLClassLoader$1.run(URLClassLoader.java:355) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:354) at java.lang.ClassLoader.loadClass(ClassLoader.java:425) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308) at java.lang.ClassLoader.loadClass(ClassLoader.java:358) at com.simsilica.lemur.GuiGlobals.<init>(GuiGlobals.java:145) at com.simsilica.lemur.GuiGlobals.initialize(GuiGlobals.java:115) at states.Main.simpleInitApp(Main.java:34) at com.jme3.app.SimpleApplication.initialize(SimpleApplication.java:226) at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(LwjglAbstractDisplay.java:130) at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:207) at java.lang.Thread.run(Thread.java:744) Caused by: java.lang.ClassNotFoundException: com.jme3.app.state.BaseAppState at java.net.URLClassLoader$1.run(URLClassLoader.java:366) at java.net.URLClassLoader$1.run(URLClassLoader.java:355) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:354) at java.lang.ClassLoader.loadClass(ClassLoader.java:425) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308) at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ... 19 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    4 times, 6 months ago
    Unknown user
    3 times, 8 months ago
    Unknown user
    3 times, 9 months ago
    Unknown user
    Once, 10 months ago
    Unknown user
    Once, 11 months ago
    1322 more bugmates