java.lang.RuntimeException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Hi, I want to install a war file generated from Jenkins to WebLogic, both on different machines, but when the installation runs an error is generated: java.lang.RuntimeException: task completed abnormally (exit code = 1) Your help please! *+Jenkins Console Output:+* [WeblogicDeploymentPlugin] - EXECUTING TASK ... $ /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java -Xms256M -Xmx256M -cp /var/jenkins_home/wls-deploy/weblogic.jar:/var/jenkins_home/wls-deploy/wlfullclient.jar:/var/jenkins_home/wls-deploy/wlthint3client.jar weblogic.Deployer -adminurl t3://10.211.55.3:12001 -user system -password system -deploy /var/jenkins_home/workspace/job-test-compile-build-deploy/dist/testcicd.war -remote -upload java.lang.RuntimeException: task completed abnormally (exit code = 1) at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.customize(DeploymentTaskServiceImpl.java:340) at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.perform(DeploymentTaskServiceImpl.java:173) at org.jenkinsci.plugins.deploy.weblogic.WeblogicDeploymentPlugin.perform(WeblogicDeploymentPlugin.java:304) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:665) at hudson.model.Run.execute(Run.java:1766) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) ERROR: [WeblogicDeploymentPlugin] - Failed to deploy. *+WebLogic Deployment Log:+* ------------------------------------ TASK EXECUTION ------------------------------------------------ weblogic.Deployer invoked with options: -adminurl t3://10.211.55.3:12001 -user system -deploy /var/jenkins_home/workspace/job-test-compile-build-deploy/dist/testcicd.war -remote -upload java.lang.NoClassDefFoundError: weblogic/deploy/api/spi/DeploymentOptions at weblogic.deploy.api.tools.deployer.Jsr88Operation.init(Jsr88Operation.java:70) at weblogic.deploy.api.tools.deployer.Operation.(Operation.java:52) at weblogic.deploy.api.tools.deployer.Operation.(Operation.java:47) at weblogic.deploy.api.tools.deployer.Operation.(Operation.java:42) at weblogic.deploy.api.tools.deployer.Jsr88Operation.(Jsr88Operation.java:55) at weblogic.deploy.api.tools.deployer.DeployOperation.(DeployOperation.java:18) at weblogic.deploy.api.tools.deployer.Deployer.newOperation(Deployer.java:219) at weblogic.deploy.api.tools.deployer.Deployer.runBody(Deployer.java:86) at weblogic.utils.compiler.Tool.run(Tool.java:159) at weblogic.utils.compiler.Tool.run(Tool.java:116) at weblogic.Deployer.run(Deployer.java:74) at weblogic.Deployer.main(Deployer.java:55) Caused by: java.lang.ClassNotFoundException: weblogic.deploy.api.spi.DeploymentOptions at java.net.URLClassLoader.findClass(URLClassLoader.java:381) at java.lang.ClassLoader.loadClass(ClassLoader.java:424) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331) at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ... 12 more weblogic/deploy/api/spi/DeploymentOptions *+Deployment Task Configuration (Job):+* The configuration can be seen in the attached images conf-1.png and conf-2.png. Command Line Options: -adminurl t3://10.211.55.3:12001 -user system -password system -deploy /var/jenkins_home/workspace/job-test-compile-build-deploy/dist/testcicd.war -remote -upload *+WebLogic Deployment Plugin Configuration:+* I tried several options, some of these options can be seen in the attached images weblogic-deployment-plugin-conf-1.png and weblogic-deployment-plugin-conf-2.png. *+plugin-configuration.xml:+* <?xml version="1.0" encoding="UTF-8"?> <config xmlns="http://org.jenkinsci.plugins/WeblogicDeploymentPlugin" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://localhost:32777/plugin/weblogic-deployer-plugin/config/plugin-configuration.xsd"> <weblogic-targets> <weblogic-target> <name>wls-alpha</name> <host>10.211.55.3</host> <port>12001</port> <login>system</login> <password>system</password> <authMode>BY_LOGIN</authMode> </weblogic-target> </weblogic-targets> </config> *+Deploy from WebLogic Machine:+* The deploy from the weblogic machine is performed without errors, this can be seen in the attached image deploy-from-weblogic-machine.png
    via by Guillermo Figueroa,
  • Weblogic Deployer plugin errors
    via by Vijay Patel,
    • java.lang.RuntimeException: task completed abnormally (exit code = 1) at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.deploy(DeploymentTaskServiceImpl.java:244) at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.perform(DeploymentTaskServiceImpl.java:173) at org.jenkinsci.plugins.deploy.weblogic.WeblogicDeploymentPlugin.perform(WeblogicDeploymentPlugin.java:239) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668) at hudson.model.Run.execute(Run.java:1763) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410)

    Users with the same issue

    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,