com.sun.xml.internal.ws.server.ServerRtException

tip

It might be that there's another process connecting to the same port you're trying to use, try to kill it or change the connection port.


rafaelrafael
tip

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

tip

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.


rafaelrafael

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Sonar started but builds are failing
    via Stack Overflow by PT_C
    ,
  • GitHub comment 16405#115663850
    via GitHub by ktoso
    ,
  • Tomcat won't start on localhost
    via Stack Overflow by dude
    ,
  • Why Smartfoxserver 2X is not running?
    via Stack Overflow by K. Ayaz
    ,
  • 开源中国(OSChina.NET)
    via by Unknown author,
    • com.sun.xml.internal.ws.server.ServerRtException: Server Runtime Error: java.net.BindException: Address already in use: bind at com.sun.xml.internal.ws.transport.http.server.ServerMgr.createContext(ServerMgr.java:102) at com.sun.xml.internal.ws.transport.http.server.HttpEndpoint.publish(HttpEndpoint.java:63) at com.sun.xml.internal.ws.transport.http.server.EndpointImpl.publish(EndpointImpl.java:171) at com.sun.xml.internal.ws.spi.ProviderImpl.createAndPublishEndpoint(ProviderImpl.java:113) at javax.xml.ws.Endpoint.publish(Endpoint.java:240) at net.ilkj.soap.server.SoapServer.main(SoapServer.java:11) Caused by: java.net.BindException: Address already in use: bind at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Net.java:344) at sun.nio.ch.Net.bind(Net.java:336) at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:199) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74) at sun.net.httpserver.ServerImpl.<init>(ServerImpl.java:101) at sun.net.httpserver.HttpServerImpl.<init>(HttpServerImpl.java:50) at sun.net.httpserver.DefaultHttpServerProvider.createHttpServer(DefaultHttpServerProvider.java:35) at com.sun.net.httpserver.HttpServer.create(HttpServer.java:129) at com.sun.xml.internal.ws.transport.http.server.ServerMgr.createContext(ServerMgr.java:84) ... 5 more

    Users with the same issue

    slashslash
    6 times, last one,
    rocdayrocday
    4 times, last one,
    bandocabandoca
    122 times, last one,
    batwalrus76batwalrus76
    1 times, last one,
    linxiaolonglinxiaolong
    1 times, last one,
    136 more bugmates