org.apache.maven.plugin.prefix.NoPluginFoundForPrefixException

No plugin > found for prefix 'maven' in the current project and in the plugin groups > [org.apache.maven.plugins, org.codehaus.mojo] available from the > repositories [local (D:\Documents and Settings\.......\.m2\repository), > central (http://repo1.maven.org/maven2)] at > org.apache.maven.plugin.prefix.internal.DefaultPluginPrefixResolver.resolve(DefaultPluginPrefixResolver.java:92) at > org.apache.maven.lifecycle.internal.MojoDescriptorCreator.findPluginForPrefix(MojoDescriptorCreator.java:262) at > org.apache.maven.lifecycle.internal.MojoDescriptorCreator.getMojoDescriptor(MojoDescriptorCreator.java:222) at > org.apache.maven.lifecycle.internal.DefaultLifecycleTaskSegmentCalculator.calculateTaskSegments(DefaultLifecycleTaskSegmentCalculator.java:106) at > org.apache.maven.lifecycle.internal.DefaultLifecycleTaskSegmentCalculator.calculateTaskSegments(DefaultLifecycleTaskSegmentCalculator.java:86) at > org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:98)

Samebug tips1

Go for Manage Jenkins -> Configure System -> Sonar -> Advanced -> Version of sonar-maven-plugin and set it for 2.1.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web76

  • No plugin > found for prefix 'maven' in the current project and in the plugin groups > [org.apache.maven.plugins, org.codehaus.mojo] available from the > repositories [local (D:\Documents and Settings\.......\.m2\repository), > central (http://repo1
  • No plugin > found for prefix 'maven' in the current project and in the plugin groups > [org.apache.maven.plugins, org.codehaus.mojo] available from the > repositories [local (D:\Documents and Settings\.......\.m2\repository), > central (http://repo1
  • No plugin > found for prefix 'maven' in the current project and in the plugin groups > [org.apache.maven.plugins, org.codehaus.mojo] available from the > repositories [local (D:\Documents and Settings\.......\.m2\repository), > central (http://repo1
  • Stack trace

    • org.apache.maven.plugin.prefix.NoPluginFoundForPrefixException: No plugin > found for prefix 'maven' in the current project and in the plugin groups > [org.apache.maven.plugins, org.codehaus.mojo] available from the > repositories [local (D:\Documents and Settings\.......\.m2\repository), > central (http://repo1.maven.org/maven2)] at > org.apache.maven.plugin.prefix.internal.DefaultPluginPrefixResolver.resolve(DefaultPluginPrefixResolver.java:92) at > org.apache.maven.lifecycle.internal.MojoDescriptorCreator.findPluginForPrefix(MojoDescriptorCreator.java:262) at > org.apache.maven.lifecycle.internal.MojoDescriptorCreator.getMojoDescriptor(MojoDescriptorCreator.java:222) at > org.apache.maven.lifecycle.internal.DefaultLifecycleTaskSegmentCalculator.calculateTaskSegments(DefaultLifecycleTaskSegmentCalculator.java:106) at > org.apache.maven.lifecycle.internal.DefaultLifecycleTaskSegmentCalculator.calculateTaskSegments(DefaultLifecycleTaskSegmentCalculator.java:86) at > org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:98) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319) at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156) at org.apache.maven.cli.MavenCli.execute(MavenCli.java:534) at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196) at org.apache.maven.cli.MavenCli.main(MavenCli.java:141) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    2 times, 4 months ago
    Unknown user
    Once, 10 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    4 more bugmates