java.lang.ClassNotFoundException

loci.formats.in.SlideBook6Reader

Samebug tips5

This might be an issue with the file location in the Spark submit command. Try it with "spark-submit --master spark://master:7077 hello_world_from_pyspark.py {file location}"


rafaelrafael

Check if you've set a name in Application -> Run. If you didn't, the generated XML is gonna have missing information and then this exception will be thrown.


rafaelrafael

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web8290

  • via GitHub by ximenesuk
    ,
  • Stack trace

    • java.lang.ClassNotFoundException: loci.formats.in.SlideBook6Reader at java.net.URLClassLoader.findClass(URLClassLoader.java:381)[na:1.8.0_65] at java.lang.ClassLoader.loadClass(ClassLoader.java:424)[na:1.8.0_65] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)[na:1.8.0_65] at java.lang.ClassLoader.loadClass(ClassLoader.java:357)[na:1.8.0_65] at java.lang.Class.forName0(Native Method)[na:1.8.0_65] at java.lang.Class.forName(Class.java:264)[na:1.8.0_65] at loci.formats.ClassList.parseLine(ClassList.java:196)[formats-api.jar:5.2.1] at loci.formats.ClassList.parseFile(ClassList.java:258)[formats-api.jar:5.2.1] at loci.formats.ClassList.<init>(ClassList.java:138)[formats-api.jar:5.2.1] at loci.formats.ClassList.<init>(ClassList.java:122)[formats-api.jar:5.2.1] at loci.formats.ImageReader.getDefaultReaderClasses(ImageReader.java:78)[formats-api.jar:5.2.1] at ome.formats.importer.OMEROWrapper.createReader(OMEROWrapper.java:131)[blitz.jar:na] at ome.formats.importer.OMEROWrapper.<init>(OMEROWrapper.java:93)[blitz.jar:na] at ome.formats.importer.OMEROWrapper.<init>(OMEROWrapper.java:89)[blitz.jar:na] at ome.formats.importer.cli.CommandLineImporter.<init>(CommandLineImporter.java:145)[blitz.jar:na] at ome.formats.importer.cli.CommandLineImporter.main(CommandLineImporter.java:947)[blitz.jar:na]

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    SteVio1989SteVio1989
    2 times, last one
    jf-astjf-ast
    Once,
    DavidDavid
    2 times, last one
    andyglickandyglick
    95 times, last one
    bandocabandoca
    2 times, last one
    1669 more bugmates