java.lang.NoClassDefFoundError

SerialAITest (wrong n ame: net/wimpi/modbus/cmd/SerialAITest)

Solutions on the web3813

  • via Oracle Community by 807549, 10 months ago
    SerialAITest (wrong n ame: net/wimpi/modbus/cmd/SerialAITest)
  • SchemaUpdate (wrong n ame: net/sf/hibernate/tool/hbm2ddl/SchemaUpdate)
  • SchemaUpdate (wrong n ame: net/sf/hibernate/tool/hbm2ddl/SchemaUpdate)
  • Stack trace

    • java.lang.NoClassDefFoundError: SerialAITest (wrong n ame: net/wimpi/modbus/cmd/SerialAITest) at java.lang.ClassLoader.defineClass0(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:502) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123) at java.net.URLClassLoader.defineClass(URLClassLoader.java:250) at java.net.URLClassLoader.access$100(URLClassLoader.java:54) at java.net.URLClassLoader$1.run(URLClassLoader.java:193) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:186) at java.lang.ClassLoader.loadClass(ClassLoader.java:299) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:265) at java.lang.ClassLoader.loadClass(ClassLoader.java:255) at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Once, 6 months ago
    Unknown user
    Once, 11 months ago